5

I have installed magento2.3.0 in localhost wamp server, It is working fine. When I'm trying to test GraphQL for PWA studio, I'm getting this error "TypeError: Failed to fetch". GraphQL Screenshot

3
  • did you ever solve this issue? I have the same problem
    – jonasG
    Commented Mar 25, 2019 at 14:30
  • facing same issue.. anyone have a solution ?
    – siddhrock
    Commented Apr 16, 2019 at 12:19
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review Commented Apr 16, 2019 at 12:48

3 Answers 3

2

You are on the right track but you can easily view Documentation when you click on Docs on the right top corner.

See screenshot with an example for the Category Query and the Documentation in the right sidebar.

GraphQl Docs Example

1
  • current it's showing NO SCHEMA AVAILABLE in Docs.
    – Mankesh
    Commented Dec 5, 2018 at 6:08
1
  1. Make sure your storefront is working
  2. Switch to developer mode
  3. Set the GraphiQL client endpoint to hostname/graphql

Does the Documentation Explorer (Docs tab) load? Do you still receive the error?

1
  • the storefront is working on developer mode on wamp server but still, the same issue is there.
    – Mankesh
    Commented Dec 5, 2018 at 6:02
0

to put the domain like http://mage230.localhost/graphql and not http://mage230/graphql

I had the same issue, but in my case I forgot the http:// now with a url http://mydomain.test/graphql it works.

Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.