0

I want to migrate Magento 1.9.2.1 to Magento 2.3 (Without Sample Data). But, when I execute composer update command. It's return some errors.

The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("1.0.0"). You may need to run composer update with the "--no-plugins" option.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/product-community-edition 2.3.0 requires magento/inventory-composer-metapackage ^1.0.3 -> satisfiable by magento/inventory-composer-metapackage[1.0.3].
    - magento/product-community-edition 2.3.0 requires magento/inventory-composer-metapackage ^1.0.3 -> satisfiable by magento/inventory-composer-metapackage[1.0.3].
    - magento/inventory-composer-metapackage 1.0.3 requires magento/inventory-composer-installer ^1.0.3 -> satisfiable by magento/inventory-composer-installer[1.0.3].
    - magento/inventory-composer-metapackage 1.0.3 requires magento/inventory-composer-installer ^1.0.3 -> satisfiable by magento/inventory-composer-installer[1.0.3].
    - magento/inventory-composer-installer 1.0.3 requires composer-plugin-api ^1.1 -> no matching package found.
    - magento/inventory-composer-installer 1.0.3 requires composer-plugin-api ^1.1 -> no matching package found.
    - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

When, I run with composer update --no-plugins command. Still, It returns same error.

It seems like need to upgrade composer version. But, I'm not sure.

How to solve this error and successfully migrate in Magento 2.3?

Please help me.

Thanks.

0

I find solution myself. It needs to upgrade composer in your system.

For that, Need to follow this steps. Please click here.

|improve this answer|||||
  • I follow the step which mentioned in the above URL and still showing the old version of the composer in the Magento installation directory. I changed the last step to the Magento root directory and no luck on that. Can you please explain the steps which you have done? – Shafeeque S Dec 3 '18 at 19:46
  • After that you need to replace composer file : mv composer /usr/local/bin/ – Rohan Hapani Dec 4 '18 at 5:43
  • Execute this command and then apache restart – Rohan Hapani Dec 4 '18 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.