0

Does anyone know how to fix the email sender to look more professional? The image below is an email confirmation for an order I placed in the Magento Marketplace...even they can't make it look good: Marketplace Order Email

I have the same problem on my Magento 2 install. Transactional emails show up as coming from some garbledy gook email that is associated with the actual web server's user. It's ugly and doesn't scream professional at all. Other emails, such as a contact-us form, don't have the same problem. I've heard you can fix this using an SMTP extension, but I've had problems with emails not working at all when I use those. If that's the only solution I'll see if I can get it to work. But why is this the default functionality for an eCommerce platform?

0

When you get emails that look like they're coming from a system user (on Linux at least, IDK about Magento on Windows) it's a safe bet that the site is using a local mail relay like sendmail or Postfix. The easiest fix is to have Magento use a 3rd party API for mail sending, at this point there are a lot of them out there that have free usage tiers, and many that have Magento plugins already built.

  • Of note, while I've set up Postfix for system mail and used it for local dev, I think most every Magento site I've worked on has used a 3rd party email sender in production. Probably the most popular I've come across is MailChimp, but that might just be luck of the draw. – siliconrockstar Mar 5 at 17:46
  • Thanks for your answer, I'll look into it. Do you know why the transactional emails have this issue but the Contact Us form doesn't? It must be using 2 different mail apps or using them in different ways, but I haven't been able to figure it out. – BrianVPS Mar 6 at 19:17
  • Update: looks like SendGrid is the 'preferred' mail transport agent for Magento 2 - magento.stackexchange.com/questions/252023/… – siliconrockstar Sep 9 at 17:18
1

There's a few solutions that are possible here.

From your admin dashboard, navigate to Stores>Configuration>General>Store Email Addresses. From there, make sure your email addresses are all set properly.

There's also a few sender settings in Configuration>Sales>Sales Emails.

If all of that is set, check your php.ini for sendmail settings. There's also /etc/hosts/ and /etc/mail/, but that may be dependent on your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.