the problem is usually composer and dependencies-specific, you just need to understand what Composer is telling you. Obviously, something in Magento need to be updated or "tweaked".
Composer is telling you that some requirements are not met: it's not telling your php version is not supported by Magento framework, it's saying that due to some requirements (that you can find in extension-specific composer.json) your current php version can't be used.
You are simply supposed to look into those extensions, update them first (their composer.json), then re run the update: you should find a hint in the error message that points to a specific extension.
Let's make a practical example:
you've got extension "myext" composer.json requiring magento/framework<102.0.0
If you try to upgrade to Magento 2.3.2 it will fail because Magento 2.3.0 will need at least magento/framework=102.0.0 but your extension can't run with 102.0.0 (is set to require a <102.0.0).
Requirements can't be met and Your requirements could not be resolved to an installable set of packages.
In the error message composer could also tell you that the extension will need a older php version to be able to run.
So look broader in the composer error message: you'll find the extensions that need to be upgraded first.
To take the answer even to a broader possible set of composer-related errors: it's important to remember that even if you're updating to a magento version that supports newer php versions you're sometimes forced to use the older to perform the upgrade (this is the case when upgrading from 2.2.8 to 2.3.2 : you upgrade using 7.1 then only after you can switch to 7.2). MageDevdocs can be very useful here.
Remembe that Composer is all about "Dependency Manager for PHP"