0

Summary of the issue

I cannot run the developer mode after I've done the steps below to upgrade to Magento 2.3. The upgrade process ended up with: Service Temporarily Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Preconditions

  1. Magento 2.2.6
  2. Current PHP Version: PHP 7.1.22

Steps to Reproduce

  1. Connect via SSH.
  2. Run this command line:

    composer require --dev phpunit/phpunit:~6.2.0 friendsofphp/php-cs-fixer:~2.10.1 lusitanian/oauth:~0.8.10 pdepend/pdepend:2.5.2 sebastian/phpcpd:~3.0.0 squizlabs/php_codesniffer:3.2.2 --no-update

    Note that I did not switch to the developer mode.

  3. Go to Magento backend.

  4. Go to System > Web Setup Wizard and click on system upgrades to start the update process.

You will not get success message that the update is successful.

Go to SSH and run this command:

deploy:mode:set developer

Expected and actual results

The command must run as usual but it did not. I got the below error message:

#0 /chroot/home/[MY ROOT]/vendor/zendframework/zend-servicemanager/src/Config.php(137): Zend\ServiceManager\ServiceManager->addAbstractFactory('Zend\\Mvc\\Contro...')
#1 /chroot/home/[MY ROOT]/vendor/zendframework/zend-modulemanager/src/Listener/ServiceListener.php(225): Zend\ServiceManager\Config->configureServiceManager(Object(Zend\Mvc\Controller\ControllerManager))
#2 [internal function]: Zend\ModuleManager\Listener\ServiceListener->onLoadModulesPost(Object(Zend\ModuleManager\ModuleEvent))
#3 /chroot/home[MY ROOT]/vendor/zendframework/zend-eventmanager/src/EventManager.php(490): call_user_func(Array, Object(Zend\ModuleManager\ModuleEvent))

How can I correct this issue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.