0

Is there any way to upgrade from Magento 2.2.6 to 2.3 using the Web Setup Wizard? I'm getting the following error:

Check Component Dependency
We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].
- magento/module-wishlist-sample-data 100.2.0 requires magento/module-wishlist 101.0.* -> satisfiable by magento/module-wishlist[101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5].
- Can only install one of: magento/module-wishlist[101.1.0, 101.0.0].
- Can only install one of: magento/module-wishlist[101.1.0, 101.0.1].
- Can only install one of: magento/module-wishlist[101.1.0, 101.0.2].
- Can only install one of: magento/module-wishlist[101.1.0, 101.0.3].
- Can only install one of: magento/module-wishlist[101.1.0, 101.0.4].
- Can only install one of: magento/module-wishlist[101.1.0, 101.0.5].
- magento/product-community-edition 2.3.0 requires magento/module-wishlist 101.1.0 -> satisfiable by magento/module-wishlist[101.1.0].
- Installation request for magento/module-wishlist-sample-data 100.2.* -> satisfiable by magento/module-wishlist-sample-data[100.2.0].

Please see screenshot:

enter image description here

My PHP version is 7.1.18 on CentOS 7, no Composer.

  • Possible duplicate of Cannot upgrade from 2.2.6 to 2.3 via composer – sv3n Nov 30 '18 at 15:00
  • Not a duplicate. I'm asking how to upgrade via the Web Setup Wizard, not Composer. – GTS Joe Nov 30 '18 at 15:02
  • Sorry, my bad. Solution shoud be the same to remove sample data before upgrading. – sv3n Nov 30 '18 at 15:03
0

The Web Setup Wizard still uses Composer to do the upgrade, and the same changes are necessary before running a Wizard upgrade as they are a Command Line upgrade; the answer to Cannot upgrade from 2.2.6 to 2.3 via composer also applies here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.