0

I was Upgrade Magento from 2.1.12 to 2.3 using Web Setup Wizard. During this process, It show two error PHP Settings Check and Checking Component Dependency.

We already set memory_limit=2GB in php/php.ini, But it show same error. Please Guide me.

  • Did you upgrade? @Lovely Setia – Gem Dec 28 '18 at 9:52
0

Try below solution for memory limit

If you got composer memory allocation error try below way

php -d memory_limit=-1 /usr/bin/composer install
php -d memory_limit=-1 /usr/bin/composer update

If you got an error in setup to upgrade or static content deploy try below way

php -dmemory_limit=6G bin/magento setup:upgrade 
php -dmemory_limit=6G bin/magento setup:static-content:deploy -f

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.