1

I've added four nearly identical products to my brand new Magento 1.9 store. Each one with complete information, including weights.

Then I set up a shipping rate table, and successfully imported the CSV. I confirmed this in the "shipping_tablerate" db table using phpMyAdmin. The CSV that I'm using for debugging looks like this:

Country,Region/State,Zip/Postal Code,Weight (and above),Shipping Price
USA,*,*,0,1000

This rate is reflected correctly for one of my products when I add it to the cart and estimate shipping. However, for my remaining three products, it estimates shipping to be $0.00.

I can't figure out what is causing this odd behavior for the life of me.

65 lb product (??? $0.00 rate)

65 lb product (??? $0.00 rate)

85 lb product (correct $1000.00 rate)

85 lb product (correct $1000.00 rate)

Any ideas? I've burnt most of the day on this problem.

1

What comes in my mind:

  1. is it a simple item, not a virtual one
  2. has it set weight
  3. is there any rule or setting on the item, for free shipping
  4. is there some rule for free shipping from 700$ or something
  • It was the result of a promotion. So basically #4 on your list. Thank you so much! It didn't even occur to me. Ugh. The demo content and settings can be just as much a curse as they can be a blessing. – user9629 Jun 27 '14 at 0:09
  • There is NO reason to built a shop on demo data. Beside of the collateral damage like this, the data are broken – Fabian Blechschmidt Jun 27 '14 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.