4

I have started working with magento earlier this year, I am running magento CE 2.2.2

I have noticed that when I go back to edit a product from the catalog I have noticed that the categories are not listed.

I have checked the frontend and item visible in the category, the problem is in the backend, you can see the attachment image below.

Does anyone encounter the problem or know a solution that can be applied?

here you can see the categories I chose during product setup: enter image description here image url

but it is showing like this when I go to edit, which makes it impossible to edit categories: enter image description here image url

  • please try to add category after re-indexing – Aasim Goriya Nov 27 '18 at 8:42
  • When I tried to add a product to a category, it showed fine but when I click save, it disappeared from the list. but the same thing when I went to the frontend I could see the item fine. – Robert Micallef Nov 28 '18 at 12:19
  • 1
    Hi Did you find the solution for this issue. I am also facing the same issue – Dalbin Shimy Dec 10 '18 at 10:27
  • @DalbinShimy no, unfortunately, I could not find a solution. to make it more complicated... I downloaded a backup on my local xampp server, and after running reindex command, everything worked fine. So then I thought that the problem is from the hosting, but my hoster told me that there is nothing wrong... Still not sure about this. – Robert Micallef Dec 11 '18 at 11:11
  • Hi Robert. Thanks for the reply. It is working fine in my local but not working in live or dev site. – Dalbin Shimy Dec 11 '18 at 11:58
0

Solution is following sequence of commands:

sudo chmod -R 777 var/ generated/ pub/static/ app/etc/ pub/media/
php bin/magento indexer:reindex
sudo chmod -R 777 var/ generated/ pub/static/ app/etc/ pub/media/
php bin/magento cache:flush

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.