0

If I upload a special price with a local API programm, the price in the product view is ok, but in the category view its still the old price, I allready flushed all caches in the Magento backend, but no change. If I go in the backend into the product and save it again, its updating the price in the category view also.

  • Did you reindex? – Haim Nov 25 '18 at 17:29
  • No, because it was working the whole time I did programm the API APP. now I reindexed and the prices are equal. – Michael Müller Nov 25 '18 at 19:28
  • So how can I solve this problem then? I cant reindex on each price update. We have update every coupld minutes. – Michael Müller Nov 25 '18 at 19:29
0

It seams that the reindexer was set to update by crown job.

From Magento 2 DevDocs: Configure indexers

To specify the indexer configuration:

bin/magento indexer:set-mode {realtime|schedule} [indexer]

Where: realtime - Sets the selected indexers to update on save. schedule - Sets the specified indexers to save according to the cron schedule. indexer - Is a space-separated list of indexers. Omit indexer to configure all indexers the same way.

After setting it to "realtime" it works.

bin/magento indexer:set-mode realtime
0

Here is another answere:

Trough the Magento special price API which you find in swagger under

catalogSpecialPriceStorageV1

you can upload many special prices for one SKU. So if you upload one yesterday and its not valid anymoe you should delete it.

You can see which are active with:

/V1/products/special-price-information

and you can delete all here with

/V1/products/special-price-delete

More details under

yourmagentodomain.com/swagger/

If you dont do so, many specials can conflict the current one and it will only be active in the backend. Maybe this is a bug but that how it works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.