0

So after migrating to a new server, I stopped receiving the Order copy emails to the sales representative or any other specified.

Default is info@shopdomain.co.uk, I also tried @gmail.com, none of the receive the order copy.

The client is receiving the order email fine.

info@shopdomain.co.uk is managed with google G suite. I tried to make a test and see if maybe server is failing to send emails to that email:

using cli mail command I can send emails and info@shopdomain.co.uk receives them. Cron is running fine, I can see tasks working.

edit 27/11

The first problem was Reverse DNS not working, thus some clients got emails but to the spam folder, fixed that and added SPF and now everyone is getting emails.

The second problem I see that my default scope settings are being ignored and website scope is used for sending emails, but also only if I add the email info@shopdomain.co.uk to "Send order copy email to". So why Sales rep dont get the email if he has the same email- info@shopdomain.co.uk?

enter image description here

Why default is being overridden by website scope?

  • Is other email sent successfully? or just order email not sending – Hitesh Nov 23 '18 at 7:09
  • Which one you have in mind? – SPL Nov 23 '18 at 7:23
  • You can try by subscribing for newsletter with any other email.. If it is sending subscription success/unsuccess mails then something wrong with code otherwise you have to check with mail service installed on server.. – Himmat Paliwal Nov 23 '18 at 9:31
  • added new edit 27/11 – SPL Nov 27 '18 at 6:44
0

The problem was with DNS settings. Fixed them, no more blacklist blocking and everyone gets emails

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.