6

I'm hoping to get some advice. I pulled a project that I haven't touched in some time and in developer mode I ran 'grunt exec' followed by 'grunt less' and once running 'grunt less' I receive the following error. Magento 2.2.6

Running "less:documentation" (less) task

NameError: .lib-url-check is undefined in lib/web/css/docs/source/_utilities.less on line 402, column 5: 401 // "Call" the mixin 402 .lib-url-check(@_icon-image); 403 Warning: Error compiling lib/web/css/docs/source/docs.less Use --force to continue.

Aborted due to warnings.

The code for around line 401:

.example-url-check-false {
    //  Set usage image path to false
    @_icon-image: false;

    //  "Call" the mixin
    .lib-url-check(@_icon-image);

    //  Will return 'false' and outputs nothing
    .lib-css(background, #eee @lib-url-check-output no-repeat 0 0);
}

This file is an unmodified core file, how do I go about debugging the cause of this issue/resolve.

I'd appreciate any help I can receive.

Thanks!

  • I am having the same issue right now, any update on this? – hallleron Mar 1 at 7:47
0

I wouldn't worry that much about those compiling issues, because:

  1. Is for the own lib built on Magento documentation pages. lib/web/css/docs/. Check that you have built HTML pages with 'How to' stuff.
  2. If the compile breaks and annoys you check the source file and remove the line or comment it.
  3. You can always skip the :documentation in grunt by being specific on your compiles.

There is a slight chance that the new upgrades changed some of the docs libraries and they forgot to update some of the mixins properly.

0

As of 2.3, the :documentation compile option can be skipped via dev/tools/grunt/configs/less.js.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.