2

I have a problem with a Magento2 installation.

If I am logged in as a client on a browser, with another browser (client not logged in). If I do the same actions on both browsers, the second browser (on which I was not connected) takes the first session ....

I Try this solution : Suddenly started using another logged in user's session - Magento 2

But It doesn't work

SID is disabled

I have the problem that the cache is enabled or disabled

And I still have the problem if session are stored on files or on db

After some modifications, it seems that the session is no longer "stolen". By cons there is always a problem in the display. For example with my logged session I go to https://example.com/customer/account/ as well as with my unlogged session at the same time: on the unlogged session I see the information of the other session.

I'm thinking of a cache problem, but by completely disabling the cache :

php bin/magento cache:disable

the problem persists

someone would have an idea of the origin of the problem?

It seem's that is a server issue, on my chrome console I've got this message :

Error parsing header X-XSS-Protection: 1; mode=block, 1; mode=block: expected semicolon at character position 13. The default protections will be applied.
  • You have issue in login Magento admin at a time same user with multiple browser Right ? – Kirti Nariya Nov 22 '18 at 15:58
  • @KirtiNariya no the issue takes place on the frontend side. I am connected as a customer on a browser and on the other not – Gildas Ross Nov 22 '18 at 16:59
  • Which Magento version are you using ? – Kirti Nariya Nov 22 '18 at 17:05
  • it's Magento 2.2.5 – Gildas Ross Nov 22 '18 at 17:27
0

For fix Customer login issue in multiple browser change "Share Customer Accounts" to "Global"

Follow below path in admin:

Admin >> Stores >> Configuration >> CUSTOMERS >> Customer Configuration >> Account Sharing Options >> Share Customer Accounts to "Global"


Let me know if any issue.

Hope it help!

  • it doesn't work, the issue is still here – Gildas Ross Nov 22 '18 at 17:25
  • Try to flush cache run this command: php bin/magento cache:flush – Kirti Nariya Nov 22 '18 at 17:27
  • I already emptied the cache. even with the cache off (php bin/magento cache:disable) the issue is persistent – Gildas Ross Nov 22 '18 at 17:32
  • Okay. Then you can debug you issue to disable all third party and custom created module. And then check. – Kirti Nariya Nov 22 '18 at 17:34
  • Try to disable all external module, set the default theme.... nothing the issue is still here... I re-install a clean version of Magento Without external code I got the same issue... – Gildas Ross Nov 22 '18 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.