1

I am getting the error on a standard install of Magento 1.9.3.9 using Magento Sample Data and using the Migration to for Magento 2.2.6. These are both new vanilla installations.

I am getting the following error when migrating Open source 1.9 to Open source 2.2.6

Record structure does not contain field is_used_for_customer_segment

I thought this was an EE attribute?

I have tried adding this to the ignore in the map.xml and also in the map-eav.xml (Both did not work)

1

Strange. I have a vanilla Magento 1.9.3.9 installation and as expected, it does not have the is_used_for_customer_segment attribute. But migrating from there to Magento 2.2.6 gives me zero issues. The only place in the migration toolkit where the attribute is mentioned (apart from tests) is etc/opensource-to-commerce/map-eav.xml.dist. Could it be that this error is actually thrown exactly because of the ignore?

  • I restore to 2.2.5 and it worked fine. I am clearing everything and trying again with 2.2.6 – brentwpeterson Nov 20 '18 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.