1

I'm facing an issue on Magento 2.2 . The details are as under

1.Go to home page

2.Click 'Sign In' from header

3.Enter login credentials to enter customer account

4.Click website logo to go back to home page

5.Notice that on the home page the header is still showing 'Sign In' instead of showing the customer is logged in and a 'Sign Out' link.

can anybody help me out

  • did you manage to solve this? I am facing this issue on 2.3.3. I have both redis and varnish. – Zoya Dec 13 '19 at 16:50
  • @Aqib What is the solution for this? Even i am facing same issue. – Nafsss Sep 7 at 11:40
1

I was facing the same issue as you are. It was a conflict with varnish cache.

But after I removed var and pub/static directory except .htaccess file my issue was solved.

As per my suggestion you can try to remove var and pub/static except .htaccess file.

Magento root directory run below commands:

  • rm -rf var/* pub/static/*
  • php bin/magento setup:upgrade
  • php bin/magento setup:static-content:deploy
  • php bin/magento cache:flush

Let me know if any issue.

Hope it help!

| improve this answer | |
0

Try to check your browser console log. Magento reloads this information with Javascripts. Console can show some hints for fixing this issue. Also this issue can be related to updating customer section data.

| improve this answer | |
-1

It is only the caching issue, flush cache Storage, flush Javascript cache, flush Magento cache and Refresh All type of cache from admin.Then remove browser cache and check. It works.

| improve this answer | |
  • 1
    so we are supposed to flush cache every time after after sign in/sign out? – Zoya Dec 13 '19 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.