1

I don't know much about Magento but I've been tasked with writing a module at work. I've been testing it on a local Magento 1.8.1 install with almost completely default options. The time has come to move to integrating it with an existing Magento 1.8.0 setup. With this new setup, I'm encountering a problem that I never had in testing.

When I create a new customer group and assign customers to it, those customers then can't see any of the products that would be shown if they were in the default General group. For these custom group customers, I see no products in any category.

I've looked at all the likely options in the admin panel and searched around on the internet but I couldn't find anything. What could be the cause of the problem? Is it a config setting or a module they've installed or something else entirely?

Thanks, friends!

  • 1
    Try reindexing the catalog product indexes. This can be done from the command line by running shell/indexer.php. php shell/indexer.php reindexall – Si Griffiths Jun 25 '14 at 15:50
  • @SiGriffiths That did the trick. Thank you, most noble and valiant of sirs! – Elliott Jun 25 '14 at 16:51
  • Nice one, I'll add this as an answer then and if you would accept it that would be most superb. – Si Griffiths Jun 26 '14 at 11:10
  • @Elliott could you please mark this question as answered? – philwinkle Jul 27 '14 at 5:22
2

Because customer groups are linked to the product price indexes via an inner join if the indexes are not available or complete then no products will show for that particular customer group.

To fix this reindex the product price index via the cli shell script:

php shell/indexer.php reindexall

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.