0

CSV for product image uploading

I am trying to bulk upload images for products I am getting the following error:

imported resource (image) could not be downloaded from external resource due to timeout or access permissions in row(s): 1

The product uploading works fine via csv but images are not uploading via csv. I have attached an image for reference. there are total 56 products.

I have removed pub/media/import from the csv as well but that didn't make a difference, the folder permission is 711, the magento version is 2.2.5

  • Have you tried uploading actual images to your server? I mean when you want to import products you have to manually upload images on correct path. – Korbin Nov 14 '18 at 12:33
  • They are uploaded to pub/media/import when Im uploading this file. Can you elaborate what you mean? – paranoid kid Nov 14 '18 at 12:36
  • I mean the same, so image files are there. I guess you can ignore this csv error and then try to reindex:indexer and flush:cache. – Korbin Nov 14 '18 at 12:39
  • Okay, i'll try it out. – paranoid kid Nov 14 '18 at 12:44
  • Why don't you try with Magmi? – Gem Feb 20 at 11:37
0

I had this problem too. In my case the images where located outside the magento root (symlinked). Since Magento 2.1.14 validatePath() is called in

module-catalog-import-export/⁨Model/⁨Import⁩/Uploader.php->setTmpDir()

This is why importing images from a symlinked directory does not work any more. Moving the images into the magento root was the solution in my case.

  • Yep and I removed the pub/media/import and worked after that – paranoid kid Jan 24 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.