1

Impossible run command: php bin/magento setup:di:compile

return error:

[@s1 public_html]$ php bin/magento setup:di:compile
PHP Fatal error:  Uncaught Error: Cannot use object of type __PHP_Incomplete_Cla                        ss as array in /home/czasowe/domains/mywebsite.com/public_html/vendor/mag                        ento/framework/ObjectManager/Factory/AbstractFactory.php:130
Stack trace:
#0 /home/czasowe/domains/mywebsite.com/public_html/vendor/magento/framewo                        rk/ObjectManager/Factory/AbstractFactory.php(230): Magento\Framework\ObjectManag                        er\Factory\AbstractFactory->resolveArgument(Object(__PHP_Incomplete_Class), 'Sym                        fony\\Compone...', NULL, 'output', 'Magento\\Setup\\M...')
#1 /home/czasowe/domains/mywebsite.com/public_html/vendor/magento/framewo                        rk/ObjectManager/Factory/Dynamic/Developer.php(34): Magento\Framework\ObjectMana                        ger\Factory\AbstractFactory->resolveArgumentsInRuntime('Magento\\Setup\\M...', A                        rray, Array)
#2 /home/czasowe/domains/mywebsite.com/public_html/vendor/magento/framewo                        rk/ObjectManager/Factory/Dynamic/Developer.php(59): Magento\Framework\ObjectMana                        ger\Factory\Dynamic\Developer->_resolveArguments('Magento\\Setup\\M...', Array,                         Array)
#3 /home/ in /home/czasowe/domains/mywebsite.com/public_html/vendor/magen                        to/framework/ObjectManager/Factory/AbstractFactory.php on line 130

Fatal error: Uncaught Error: Cannot use object of type __PHP_Incomplete_Class as                         array in /home/czasowe/domains/mywebsite.com/public_html/vendor/magento/                        framework/ObjectManager/Factory/AbstractFactory.php:130
Stack trace:
#0 /home/czasowe/domains/mywebsite.com/public_html/vendor/magento/framewo                        rk/ObjectManager/Factory/AbstractFactory.php(230): Magento\Framework\ObjectManag                        er\Factory\AbstractFactory->resolveArgument(Object(__PHP_Incomplete_Class), 'Sym                        fony\\Compone...', NULL, 'output', 'Magento\\Setup\\M...')
#1 /home/czasowe/domains/mywebsite.com/public_html/vendor/magento/framewo                        rk/ObjectManager/Factory/Dynamic/Developer.php(34): Magento\Framework\ObjectMana                        ger\Factory\AbstractFactory->resolveArgumentsInRuntime('Magento\\Setup\\M...', A                        rray, Array)
#2 /home/czasowe/domains/mywebsite.com/public_html/vendor/magento/framewo                        rk/ObjectManager/Factory/Dynamic/Developer.php(59): Magento\Framework\ObjectMana                        ger\Factory\Dynamic\Developer->_resolveArguments('Magento\\Setup\\M...', Array,                         Array)
#3 /home/ in /home/czasowe/domains/mywebsite.com/public_html/vendor/magen                        to/framework/ObjectManager/Factory/AbstractFactory.php on line 130
[@s1 public_html]$

Anyone know how to solve?

  • Is your website in production mode? I was getting the same error, just tried setting it to developer mode and again switching it back to production mode – Wasiq Shahrukh May 8 at 7:33
  • Yes, thank you. Is issues because mode production. We changed to dev mode and everything ok. – Sylvester May 10 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.