3

I'm currently using Magento 2.2.6. I've recently encountered the following error while trying to reindex the catalogsearch_fulltext:

Notice: Undefined offset: 53 in vendor/magento/module-catalog-search/Model/Indexer/Fulltext/Action/Full.php on line 384

Does anyone know how to fix this error?

Any help would be much appreciated.

  • same on my side .. maybe should check if no bug already reported in git for 2.2.6 – Adam Claudiu Nov 7 '18 at 10:39
  • I just downgraded back to 2.2.4 and is fine now; probably some time needs to pass before upgrading a store to the last version :) – Adam Claudiu Nov 7 '18 at 11:01
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Naveed Asim Nov 7 '18 at 11:20
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – Devtype Nov 7 '18 at 12:10
  • we have the exact same problem. Started this morning, we are on 2.2.6 and suspecting that it could be php-version related. We used to be on php7.0 but maybe our host switched us over to php7.1 without our knowledge. Have you gotten anywhere further with the issue? – Mikael Nov 7 '18 at 16:22
0

Have you tried resetting the index and doing a full reindex?

bin/magento indexer:set-mode realtime
bin/magento indexer:reset catalogsearch_fulltext
bin/magento indexer:reindex catalogsearch_fulltext
bin/magento indexer:set-mode schedule

Assuming you use schedule mode (which you should).

  • Hi, thanks for posting. Unfortunately I have already tried this and it hasn't resolved the issue. – otherbox Nov 7 '18 at 9:46
0

I've finally got to the bottom of the issue. It appears my hosting company had changed the version of PHP 7.0 to PHP 7.0.32 which Magento 2.2.x does not support. I updated to PHP 7.1.23 and all seems to be working correctly. This update also resolved 503 and 404 pages being shown on the frontend product info pages.

  • on my installation, updating to PHP 7.1 helped to fix the "Internal Server Errors" but it did not help to fix the Catalog Search Indexer error. Have you double checked that updating has fixed this error? By any chance, were there any 3rd party extensions/modules that you had installed? I'm stuck as well, and the indexer error will not go away. – Jason Nov 21 '18 at 2:28

protected by Community Nov 7 '18 at 18:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.