0

I'm updating a Magento 1.8 to 1.9.3.10 with the Magento connect. Everything worked fine (or at least with no visible errors during the process), but now I have all the site as a blank page, and no access to admin (blank page also).

I've followed the guide to update Magento with the connect, and everything seems to work fine, but now what is happening is:

Any frontend page is loading "for a while" then display a blank page, but the HEAD section of HTML is printed (not all, but most).

While if I try to access a backend resource, a blank page (with only one byte) is displayed.

What I have actually is this, in the system.log there are these two lines:

2018-11-06T12:44:23+00:00 ERR (3): Warning: include(/home/ggservice/ivsanbernard/app/code/core/Mage/ConfigurableSwatches/Model/Resource/Catalog/Product/Type/Configurable/Product/Collection.php): failed to open stream: No such file or directory  in /home/ggservice/ivsanbernard/lib/Varien/Autoload.php on line 94
2018-11-06T12:44:23+00:00 ERR (3): Warning: include(): Failed opening 'Mage/ConfigurableSwatches/Model/Resource/Catalog/Product/Type/Configurable/Product/Collection.php' for inclusion (include_path='/home/ggservice/ivsanbernard/app/code/local:/home/ggservice/ivsanbernard/app/code/community:/home/ggservice/ivsanbernard/app/code/core:/home/ggservice/ivsanbernard/lib:.:/usr/share/php:/home/ggservice/ivsanbernard/app/code/local/TypoStores/Less/Model')  in /home/ggservice/ivsanbernard/lib/Varien/Autoload.php on line 94

No error.log is created.

Interesting thing: if I misspelled a page, the 404 page is shown perfectly, with menu, footer, images, everything, no links is working from there.

do you have an clues? idea?

  • Did you flush the cache? – Haim Nov 6 '18 at 13:08
  • yes during the instalation, and to be sure I've deleted all the contents of var/cache/ now there are some other dirs inside, ifI delete them they are recrated upon page load. but nothign happens – Matteo Bononi 'peorthyr' Nov 6 '18 at 13:10
  • 1
    Can you try setting app/etc/modules/Mage_ConfigurableSwatches.xml to false, clear cache and reload? – Haim Nov 6 '18 at 13:12
  • that has solved the problem! may I ask you what is that and how I can recognize a similar problem? (luckily this is an update tryed in a dev server, but I will have to make it on production too). – Matteo Bononi 'peorthyr' Nov 6 '18 at 13:17
  • Something went wrong with your update and you don't have the configurable swatches module properly installed. What happens when you go to Magento connect? – Haim Nov 6 '18 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.