0

How can i solve this issue ? it is weird {{{System Messages}}{{System Messages}}{{System Messages}}{{themeMagento/backend}}}

enter image description here

This issue is appearing/ visible every where in the admin almost

enter image description here

2 Answers 2

1

This is usually caused by a corrupted js-translation.json file in these two locations:

  • pub/static/adminhtml/Magento/backend/[locale]/js-translation.json
  • var/view_preprocessed/pub/static/adminhtml/Magento/backend/[locale]/js-translation.json

You should first of all try to delete these two files and then flush cache and execute

php bin/magento setup:static-content:deploy -f [locale] -a adminhtml

If the file still gets generated containing curly braces maybe you're having an issue I also had and in database table core_config_data there are records that make the system think inline translate is on. It happened to me via the migration tool. Try setting those values to 0 and retry deploying static content.

enter image description here

Notice here the 3rd row contains a row that doesn't exist in a default installation of magento 2 but appeared after migrating data. The value was 1 and I set it to 0 and it instantly generated the proper translations.

Hope it helps you

0

go to database and verify entries in the translation table enter image description here

then execute this :

to delete all files except the .htacces enter the pub/static directory and run

find . -depth -name .htaccess -prune -o -delete then you can run

rm -rf var/cache/ var/generation/ var/page_cache/ var/view_preprocessed/

then

bin/magento set:static-content:dep -f [langages]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.