0

I want to implement a {{block type="bla/blubb"}} in a newly generated Magento Category Attribute, which is configured as a WYSIWYG field.

However, if I put my code into that attribute in the backend, it doesn't get rendered, instead I get the output {{block type="bla/blubb"}}.

The same code is working fine when I place it into a CMS Page in Magento, {{block type="bla/blubb"}} will get rendered there fine.

I installed the attribute this way:

$entityTypeId = $installer->getEntityTypeId('catalog_category');
$attributeSetId = $installer->getDefaultAttributeSetId($entityTypeId);
$attributeGroupId = $installer->getDefaultAttributeGroupId($entityTypeId, $attributeSetId);
$fieldName = 'my_attribute_name';

if (!$installer->getAttributeId($entityTypeId, $fieldName)) {
    $installer->addAttribute("catalog_category", $fieldName, array(
        "type" => "text",
        "backend" => "",
        "frontend" => "",
        "label" => "Attribute Label",
        "input" => "textarea",
        "class" => "",
        "source" => "",
        "global" => Mage_Catalog_Model_Resource_Eav_Attribute::SCOPE_STORE,
        "visible" => true,
        "required" => false,
        "user_defined" => false,
        "default" => "",
        "searchable" => false,
        "filterable" => false,
        "comparable" => false,
        "wysiwyg_enabled" => 1,
        "is_html_allowed_on_front" => true,
        "visible_on_front" => true,
        "unique" => false,
        "note" => "Description"
    ));

    $installer->addAttributeToGroup(
        $entityTypeId,
        $attributeSetId,
        $attributeGroupId,
        $fieldName,
        '10'
    );
}

What would I need to do in order to get {{ }} tags working? I've added the block already to be whitelisted in Blocks output and activated the dynamic media output, which does something else (as Marius suggested).

I'm using Magento 1.9.3.4

0

Not sure if this solves it, but you can try to set the config setting System->Configuration->Catalog->Frontend->Allow Dynamic Media URLs in Products and Categories to yes.
This will allow for sure directives like {{media ... }}. maybe it works for blocks also.

  • Already activated, not working. :( – zerokelvin Oct 25 '18 at 11:54
0

Add bla/blubb in the allowed blocks in Admin > System > Permissions > Blocks

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – Jai Oct 26 '18 at 4:11
  • 1
    @Jai updated :) – Richard Feraro Oct 26 '18 at 4:18
  • This is already enabled and is verified to be working when injecting the Code in my question in CMS blocks. They are intended to work there and do work properly. – zerokelvin Oct 26 '18 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.