Shipping Method Error

I'm running CE v and have come across an issue where only UPS and a Free Shipping setup will appear. My USPS credentials are valid. The USPS functions all worked in ce v1.8, which is the only other version I have used.

My experience with Magento is less than a year and I'm not sure where to look to find why this is going on. There is nothing in the error logs.

And, yes, I do have USPS enabled in Shipping Methods.

I searched the forums and saw a couple similar questions, but nothing that contained a working solution. I'm hoping by bumping the question perhaps someone who has solved the dilemma can provide some pointers.



  • just to check that usps is enabled for either all countries or the country that you are trying to ship to. – David Manners Jun 24 '14 at 13:41
  • It is formatted that way, yes. – Dave G Jun 25 '14 at 4:55
  • I just got a note from my magento host that this is a common problem when upgrading magento. Apparently the USPS treats the 'new' version of magento as a new store and not an upgrade to an existing store, so it disables the account. I'll verify this in the morning with USPS and see what they recommend and report back if there is a solution. – Dave G Jun 25 '14 at 4:57

The solution, discovered by hours of diligent assistance from the fine people at SimpleHelix, who host my sites is relatively simple, just wasn't obvious to a newish Magento user like myself.

It is true that the USPS invalidates accounts between major release upgrades of Magento. In my case, I upgraded from v. 1.8.1 to v. and my USPS module stopped working entirely.

To fix the problem, I re-enrolled at USPS and got a new userid and pwd. I copied those new strings to the Shipping Methods area of my admin panel, saved the changes, cleared my cache, and... waited about 24 hours for the post office servers to recognize the changes and begin returning valid data to my sites.

When speaking to the web support people at the post office, they confirmed the existence of this behavior but were not happy to call it a bug. They did however suggest that a fix may be forthcoming but did not care to offer when that might happen.

Hope my learning here helps any of the rest of you seeing the same behavior.


  • I've waited for 24 hrs post re-registering..still no luck.! What could possibly be wrong ? – Piyush Dangre May 3 '17 at 6:18
  • Please note that the original question and answer were derived from a problem three years ago. Your circumstances are likely different. Ask your question as a new post with your current details in it. – Dave G May 6 '17 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.