2

For some reason after I recently imported in products using Magmi and now my root directory for some reason is showing up in the main navigation with the category showing in a pull down. I've tried setting display in navigation menu to no but it still shows up. I've also tried to change is active to no but it still shows up. I've refreshed my computer's cache (F5) as well as Magento's. Now, when I did the bulk import from Magmi, I've included the root directory followed by the next level category on the CSV using category Id (e.g. 2, 6).

Was I not supposed to add products to the root directory? Could that have caused the issues or may be something. I appreciate any help to resolve this issue.

Thanks


I used OpenOffice and saved it as Unicode UTF-8. I can't seem to attach a file here to show the CSV. Here's a snippet of the cells that may be affecting it. Again, this is using magmi importer.

attribute_set type category_ids websites Dresses simple 2,6 base

2 is the root category. I'm not sure if I was supposed to add products to the root category or not and whether that may be causing the issue. I did also try to import the products in originally using categories column instead with both root category and category strung together with / but it wouldn't take so I used id's instead. I'm not sure if that could be a cause as well. Right now, if you click on the root category on the menu and the category beneath it, it shows that no products can be found. All other navigational links on the man menu works perfect.

It's very strange and I can't seem to find anything on this issue.

Thanks.

  • Can you give your csv format which you imported??? – Supravat M Jun 24 '14 at 5:02
1

Figured out the issue. For some reason, it must have somehow added the root category/category as a new set of category/subcategory during one of the imports using Magmi instead of adding it to the existing categories. I guess that's one of the downsides to Magmi. It doesn't have all the restrictions but things like this could happen without you knowing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.