0

I was attempting to install a Google Captcha extension from MageComp. In the install instructions it said: " It’s required to disable cache in the administration panel of your site. Go to System/Cache Management. Choose all caches and take action “Disable” then submit. "

As soon as I did this I was presented with the following error screen: There has been an error processing your request Exception printing is disabled by default for security reasons.

Error log record number: 693155652642

Now I cannot access either the website or the admin area, I just get the error screen. I tried editing the database to re-enable the Cache, however it made no difference. I should have backed up the site before I did this, but thought it would be a simple install, & that nothing would go wrong (big mistake). Below is a copy of the 'Error log record number: 693155652642' Does anybody have any idea?

a:4:{i:0;s:98:"SQLSTATE[HY000] [1045] Access denied for user 'selbergf_magento'@'localhost' (using password: YES)";i:1;s:2317:"#0 /home/selbergf/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home/selbergf/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(251): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /home/selbergf/public_html/lib/Zend/Db/Adapter/Abstract.php(448): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /home/selbergf/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 /home/selbergf/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(333): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Resource.php(93): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element))
#7 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(297): Mage_Core_Model_Resource->getConnection('core_read')
#8 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(312): Mage_Core_Model_Mysql4_Abstract->_getConnection('read')
#9 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Mysql4/Cache.php(41): Mage_Core_Model_Mysql4_Abstract->_getReadAdapter()
#10 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Cache.php(424): Mage_Core_Model_Mysql4_Cache->getAllOptions()
#11 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Cache.php(459): Mage_Core_Model_Cache->_initOptions()
#12 /home/selbergf/public_html/app/code/core/Mage/Core/Model/App.php(1101): Mage_Core_Model_Cache->canUse('config')
#13 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Config.php(404): Mage_Core_Model_App->useCache('config')
#14 /home/selbergf/public_html/app/code/core/Mage/Core/Model/Config.php(286): Mage_Core_Model_Config->_canUseCacheForInit()
#15 /home/selbergf/public_html/app/code/core/Mage/Core/Model/App.php(359): Mage_Core_Model_Config->loadModulesCache()
#16 /home/selbergf/public_html/app/code/core/Mage/Core/Model/App.php(295): Mage_Core_Model_App->_initModules()
#17 /home/selbergf/public_html/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#18 /home/selbergf/public_html/index.php(80): Mage::run('', 'store')
#19 {main}";s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";} 
  • Try to check with disable the extension. – Mayur Oct 24 '18 at 4:35
  • 1
    you have also incorrect database password see Access denied for user 'selbergf_magento'@'localhost' (using password: YES) correct it first – Hitesh Oct 24 '18 at 4:38
1

Open up app/etc/local.xml and make sure the database password is correct.

0

The cause can be one of the following:

  • MySQL password is incorrect, update app/etc/local.xml
  • localhost may not work, change it to 127.0.0.1 in app/etc/local.xml
  • Disabling your cache could have overwhelmed the MySQL database and it stopped, try restarting it
  • Clear your var/cache and/or var/full_page_cache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.