0

We have two domains, one for the german shop and one for the shop in switzerland.

The urls are like: www.mycompany.de and www.mycompany.ch

But if I open www.mycompany.ch then I get redirected to www.mycompany.de!

What might be the cause?

  • contact your domain support, tell your issue. – zus Oct 23 '18 at 11:19
  • You mean on first hit of your url it redirect to wrong url path? – Shubham Khandelwal Oct 23 '18 at 11:22
  • Do you have two main domain or one is main and other is sub domain? Did you check to core_config_data table web/unsecure/base_url and web/secure/base_url path values? check also app/etc/local.xml if there is base path url value – Hitesh Oct 23 '18 at 11:23
  • @Hit's, both are main domains. – Black Oct 23 '18 at 11:30
  • which step you follow to setup multi store with diffrent URL? – Dhiren Vasoya Oct 23 '18 at 14:07
0
  1. Are you sure that the config at each store level is set properly? i.e. each store had the correct setting for base URL?
  2. Did you clear the cache and reindex?
  3. This is a great guide on setting up Magento multistore - they are two methods, follow all the steps and you should be set.
  • Yes, the base urls are all correct, I just checked it with n98-magerun.phar sys:check. The cache was cleared and the site was reindexed, made no difference. – Black Oct 24 '18 at 10:10
  • The htaccess file is also correct, I checked if the storecode is passed to Mage::run correctly. – Black Oct 24 '18 at 11:25
  • Where is this hosted – Haim Oct 24 '18 at 14:59
  • it is resolved now, lookup my answer. – Black Oct 25 '18 at 10:00
0

I solved it, we are using the Extension "Visitor Country IP Redirect" which redirects users according to their geo location.

We simply had to add our external IP on the whitelist at the configuration scope of the switzerland store.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.