1

I am not able to open the Magento Connect Manager.

The backend is working fine, but after the login to access the Magento Connect panel I get redirected to this url showing me a blank page:

http://XX.XXX.XXX.XXX/XXXXXXX/downloader/?return=http%3A%2F%2FXX.XXX.XXX.XXX%2FXXXXXXX%2Findex.php%2Fadmin%2F#

My server is running openSuse 11.4, my Magento version is 1.8.1.0.

I have also tried to run the Magento clean up tool but nothing changed.

  • check error by uncommeting display errors line from the index.php and try refresh the page which was showing the blank.you can see now error.and solve – Pradeep Sanku Jun 23 '14 at 16:43
  • I've done it but nothing changed. Is it possibile that the magento connect page is not relying on the index.php page? – Niko Zarzani Jun 24 '14 at 7:58
2

I managed to solve my problem reading this post, I hope this answer will be useful.

My magento installation was missing php5-ftp and php5-zlib extensions. Magento calls gzcompress and ftp_connect with the error-suppression operator @ in front. This means there won't be any error messages, neither in the logs.

The following commands did the job.

zypper in php5-zlib
zypper in php5-ftp
/etc/init.d/apache2 restart
| improve this answer | |
0

Remove connect.cfg from installed_directory/downloader.

| improve this answer | |
0

When I went to do a clean "Virtualmin GPL" install on my server I found it not only assumes you want PHP-7.2, but many of the PHP libraries are now missing that something like PHP-5.6 or 5 came with especially is you are going to use 'Fcgi' for speed and/or 'SuExec'.
Just to name a few...
I had to add "php5-mcrypt", "php5.6-zip", php5.6-gd and PHP7.2 versions respectively (for PhpMyAdmin). PHP7.2 did not seem to have "mcrypt" available that is needed for the older (M1) versions of Magento.
I did find a patch to use PHP7.2 but it may not run some of the extensions as they would also need to be patched so I will stick with PHP5.6 for now.

The older Virtualmin install had an option to pick what PHP version you wanted, and this is important for the older Magento (M1) to run.
Also the PHP editor in Virtualmin does not seem to change any PHP files needed for Fast-cgi or FPM, only "mod_php".
I used to have a subscription for support, but the answers where very Dependant on specific setups so I found I could sort it out just as well on google.com anyway :-)

I also found the permissions for directories need to be '0775' for Magento Connect to work as this gives your group 'Write' permissions. I did a post in File & folder permission needed before installation of extension from Magento connect.
If you are using something like Redis cache or a FPC cache turn these off until you are done and ready for production as your browser will not keep up with the changes. As a matter of practice it might be easier to disable any cache and set cache to "files" (done in /app/etc/local.xml) so you can just delete /var/cache and /var/session. I setup a Shortcut to truncate these for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.