1

I am new on these forums and with Magento and i have a question about an issue i have been having with the "weight" attribute.

I have looked on many forums but could not find the answer i am looking for so i'd like to try it here.

My question:

I wanted to set a default value for 2 of the attributes used when creating a product. This because we use a certain shipment manager that requires these values to be set for each product.

For one attribute, i could set it without a problem (custom's description) but when i tried it for the "weight" attribute (fill in 0.1 for example) and save the attribute, the value just shows an empty text field again.

So it will not set a default value for that attribute, it just sets it back to blank after saving.

I have tried many things (setting the scope, setting it to be required, it doesnt allow me to remove it from attribute sets either) but nothing helps.

What am i doing wrong and how can i set a default value for this?

Hope you can help me with this!

2

You can't update the default attributes in magento. If you want to change the default value of weight attribute then you can execute following query:

UPDATE `eav_attribute` SET `default_value` = '2' WHERE `eav_attribute`.`attribute_code`='weight';
  • Thanks for that. I edited it in the database. It does show a default value now. I will monitor it for any problems but so far it works! Thanks a lot :) – Wouter Jun 24 '14 at 8:06
0

Weight is not a default attribute and the default cannot be set. You need wether to loop over the products to define a default weight or set for each product (that looks to me the safiest method). An other option is to create a new attribute that is called eg "weight_shipper" that you can set to 0.1 and that you can send to shipper.

Hope it helps,

  • Thanks for your answer. Sadly the extension could not use a new attribute so i could not use this option. Maybe it can help someone else :) – Wouter Jun 24 '14 at 8:07
  • and about the loop ? – Christophe Ferreboeuf Jun 24 '14 at 8:10
  • I have not tried that :) – Wouter Jun 24 '14 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.