2

Fresh installed Magento 2.2.3 with sample data everything worked fine. until I changed the deploy: mode to the developer mode. Now it is showing a blank page, there is no error only blank screen.

  • Refreshed the cache
  • Deleted all cache folders
  • Generated folder and cleared pub/static folder too (leaving .htaccess) file.
  • Recompiled the code
  • Run setup upgrade

commands but without any solution.

please help.

  • 1
    A blank page usually means php encountered a fatal error. This error should leave additional details in your server's error.log. Adding this error message here would help in getting you an answer which applies to your circumstances. – Kristof at Fooman Oct 18 '18 at 12:14
  • Have you got solution? – Chirag Patel Nov 2 '18 at 12:38
1

Please check is your error display is enable, go to app > bootstrap.php and find #ini_set('display_errors', 1); To ini_set('display_errors', 1); and check your error.

And you can also your error in var/log folder.

I hope it helps to you.

0

try to run below command once

php bin/magento setup:upgrade && php -dmemory_limit=6G bin/magento setup:di:compile && php -dmemory_limit=6G bin/magento setup:static-content:deploy -f

let me know if it still blank page

0

Try below commands

php bin/magento setup:upgrade
php bin/magento cache:clean
chmod 777 -R generated/
chmod 777 -R var/

Refersh your page

0

Give permission on below dir

chmod -R 777 generated/ pub/static/ var/

If still not working then please add below code at the top position in index.php on the root and find cause of the error.

error_reporting(E_ALL);
ini_set('display_errors', 1);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.