1

Hey so I've been wrestling with this one for a bit now. I have our store pretty much setup and am in the performance testing phase trying to get the site as speedy as possible.

I'm using Magento's built-in cache in conjunction with a cache warmer to ensure that the pages will render as soon as possible but the problem is that the cache seems to clear way too quickly. If I hit a link and refresh it immediately the page returns very quickly ~1s, but if I wait 5 minutes and then refresh the page is back to taking ~5s to respond.

I'm assuming this is due to the cache either being invalidated or just not used. I've checked the obvious stuff in the admin like the TTL is set to 86400 and the caches are enabled.

I'm not quite sure what would being causing this, any suggestions on what to check would be appreciated!

EDIT: So I enabled developer mode and took a look at the X-Magento-Cache-Debug header and it is reporting HIT for the pages when they load quickly (immediate refresh) and when they load slowly(refresh 5 min later). From this I guess I was wrong that it was the cache being cleared as it seems to be hitting the cache. Any ideas on what would be causing the slowdown?

  • what is cache warmer ? is it a 3rd party module ? – Shashank Kumrawat Oct 17 '18 at 18:39
  • Hey @ShashankKumrawat thanks for the response, it is just a little script that runs through the links in the sitemaps making a request to each one. – Daniel Black Oct 17 '18 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.