1

Magento 2.2.6 Anchor setting (ON / OFF) does not work in category setting.

Please check the screenshot below.

enter image description here

I have not found a solution.

Could you please help me?

nice to meet you.

4
  • does the toggling of button work? – John Oct 17 '18 at 6:59
  • Yes. It will turn green when saved in the on state. – mr.hironobu Oct 17 '18 at 7:02
  • then what was the problem? its not clear. – John Oct 17 '18 at 7:13
  • Detailed search will continue to be output to category page. I want to hide it, so I want to use the Anchor. – mr.hironobu Oct 17 '18 at 7:18
0

Try Reindexing manually and clear cache

php bin/magento indexer:reindexall
php bin/magento cache:flush
3
  • I tried that procedure already. – mr.hironobu Oct 17 '18 at 7:27
  • Do you have any custom module installed for category page? – Twinkle Oct 17 '18 at 7:31
  • Also try to use it in "all store view" instead of using specific store view.. then see if it works or not. – Twinkle Oct 17 '18 at 7:33
0

I found a solution. However, it is a but a substitution.

Remove the filter navigation from the back end with custom layout for each category.

<referenceContainer name="catalog.leftnav" remove="true" />

enter image description here

Probably, it seems to be a malfunction that exists from the beginning of Magento 2. The following is a problem that has been submitted to the Magento 2 project.

https://github.com/magento/magento2/issues/7765

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.