2

I have created a custom module in Magento 2. In developer mode it is working well, however same module does not show any content in the production mode of Magento its show only white screen. There is no error in logs, apache, system, debug logs are empty. Any suggestions?

  • dId you tried php bin/magento setup:di:compile command? Also check permission when you switch to Production mode. – Abhishek Panchal Oct 16 '18 at 20:14
  • Yes i did php bin/magento setup:di:compile but no luck and my controller file has these permission (-rw-rw-r--) – Muhammad Ayaz Oct 16 '18 at 20:51
  • @MuhammadAyaz how did you solve this, am facing the same issue – Daniel_12 Jul 11 at 13:06
  • @Daniel_12, I was having issue with the controller. Actually I was using git for version control, however the modified controller file did not update due to some reason thats way I was getting the error at product mode. Once I fixed the controller it worked for me. – Muhammad Ayaz Jul 11 at 14:27
1

Ran into this error myself. In my instance the issue was with the name of the controller file.

The controller file was name /Controller/Index/index.php

When it should have been /Controller/Index/Index.php

Apparently it worked with a lower case i in developer mode but stopped working in production mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.