1

Magmi says for updating products two columns are necessary:

  • sku
  • store

As it's not obvious what store should contain I use store code which is english. I went for updating two products as following:

"sku","store","name"
"100000000001","english","Test1"
"100000000008","english","Test2"

Selected the file containing above rows in var/import then chose Update existing items only.... It then took a few seconds to finish.

Runtime infos
Initialized attribute_set_infos!
Skus imported OK:2/2

Now as I see in both products edit pages, name fields are updated. But products grid in admin (admin/catalog_product/index/) doesn't reflect changes. It still shows previous values. This is where I ended:

mysql> select * from catalog_product_entity_varchar where entity_id = 5000 and attribute_id = 71;
+----------+----------------+--------------+----------+-----------+-------+
| value_id | entity_type_id | attribute_id | store_id | entity_id | value |
+----------+----------------+--------------+----------+-----------+-------+
|   601412 |              4 |           71 |        0 |      5000 | MS506 |
|   602135 |              4 |           71 |        1 |      5000 | Test1 |
+----------+----------------+--------------+----------+-----------+-------+
2 rows in set (0.33 sec)

I tried to add store_id column in CSV header line with corresponding 0 values but it didn't change the one with store_id=0 in above result set.

What am I missing in updating products with Magmi?

  • try with re-indexing from backend. – Shashank Kumrawat Oct 16 '18 at 18:46
  • How do you think it is related to indexing? – revo Oct 16 '18 at 18:55
0

Did you try to launch reindex via System > Index Management > Select All > Reindex Data > Submit?

It seems to be index issue, as the values in the grid you're viewing are retrieved from the index tables in the DB, not from the ..._varchar, etc, tables.

| improve this answer | |
  • Yes I'd done this php shell/indexer.php --reindexall before asking the question. – revo Oct 16 '18 at 18:54
  • Have you flushed the cache after that? – Nikita Abrashnev Oct 16 '18 at 19:18
  • No since all caches are disabled. – revo Oct 16 '18 at 19:20
  • Did you notice the first row in output? That's the problem. – revo Oct 16 '18 at 19:21
0

There are two store views and I had to update both: admin store which default values are stored in and english which is my current store code. Fortunately, Magmi accepts store codes separated by comma the same as below:

"sku","store","name"
"100000000001","english,admin","Test1"
"100000000008","english,admin","Test2"
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.