1

I want to upgrade my website with the latest version. I am using below commands:

composer require magento/product-community-edition 2.2.6 --no-update

composer update

I am getting below error:

Problem 1
    - magento/product-community-edition 2.2.6 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1] but these conflict with your requirements or minimum-stability.
    - magento/product-community-edition 2.2.6 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1] but these conflict with your requirements or minimum-stability.
    - Installation request for magento/product-community-edition 2.2.6 -> satisfiable by magento/product-community-edition[2.2.6].

enter image description here

How can I solve this error and complete upgradation of latest magento version?

My Composer.json code:

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.1.5",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/product-community-edition": "2.2.6",
        "composer/composer": "1.1.2 as 1.0.0-beta1",
        "magento/data-migration-tool": "2.1.5",
        "paradoxlabs/authnetcim": "^4.0",
        "ebizmarts/mailchimp-lib": "^3.0",
        "phpoffice/phpexcel": "^1.8"
    },
    "require-dev": {
        "phpunit/phpunit": "4.1.0",
        "squizlabs/php_codesniffer": "1.5.3",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.2.2",
        "fabpot/php-cs-fixer": "~1.2",
        "lusitanian/oauth": "~0.3 <=0.7.0",
        "sebastian/phpcpd": "2.0.0"
    },
    "config": {
        "use-include-path": true
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": "app/code/"
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "alpha",
    "prefer-stable": true,
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://repo.magento.com/"
        },
        "magento": {
            "type": "composer",
            "url": "https://repo.magento.com"
        }
    },
    "extra": {
        "magento-force": "override"
    }
}
  • got any solution ? – Pawan Oct 15 '18 at 16:32
  • Yes, I have replaced my composer.json from the same version, then it is working. – Vinod Kumar Oct 16 '18 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.