0
[2018-10-07 04:21:39][INFO][mode: data][stage: integrity check][step: Url Rewrite Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:39][INFO][mode: data][stage: integrity check][step: Log Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:39][INFO][mode: data][stage: integrity check][step: Ratings Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:39][INFO][mode: data][stage: integrity check][step: ConfigurablePrices step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:39][INFO][mode: data][stage: integrity check][step: OrderGrids Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:39][INFO][mode: data][stage: integrity check][step: Tier Price Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:39][INFO][mode: data][stage: integrity check][step: SalesIncrement Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:39][INFO][mode: data][stage: setup triggers][step: Stage]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:43][INFO][mode: data][stage: data migration][step: EAV Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:46][INFO][mode: data][stage: volume check][step: EAV Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:46][INFO][mode: data][stage: data migration][step: Customer Attributes Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:59][INFO][mode: data][stage: volume check][step: Customer Attributes Step]: started
100% [============================] Remaining Time: < 1 sec
[2018-10-07 04:21:59][INFO][mode: data][stage: data migration][step: Map Step]: started
21% [=====>----------------------] Remaining Time: 3 mins
[2018-10-07 04:22:52][ERROR]: Record structure does not contain field points_action

enter image description here

0

With 2.2.6 it seems that the source fields mapping needs to be more explicit.

You're probably using an old extension (maybe sweet tooth?) that has added some extra columns into your tables. You need to tell the migration tool to ignore these new fields.

The tool actually provides you with the list of fields it's going to have a problem with in orange in your graphic.

What you then need to do is edit your map.xml file for your chosen version i.e.

copy: data-migration-tool/etc/opensource-to-opensource/1.7.0.2/map.xml.dist

to: data-migration-tool/etc/opensource-to-opensource/1.7.0.2/map.xml

Then in your data-migration-tool/etc/opensource-to-opensource/1.7.0.2/config.xml you should change the section that points to the map file:

<map_file>etc/opensource-to-opensource/1.7.0.2/map.xml</map_file>

Within that map.xml file, you can now add the fields to the ignore list - specifically under the

<source>
  <field_rules>

node. Don't get this confused with the "destination" section.

I'd typically add them to the bottom of the field rules section. So taking the "points_action" as an example - the end of that node would look something like this:

<source>
  <field_rules>
      <.../>
      <ignore>
        <field>salesrule.points_action</field>
      </ignore>
  </field_rules>
</source>

The red error will just show when the tool hits the first field that is not mapped, so unfortunately you're not going to get away with just this one change as it'll just flag another and another across the different tables.

The trick is to use that orange "Warning" text in your terminal, to map out the fields you're going to ignore and place them in your map.xml using the format:

<ignore>
    <field>[tablename].[field_name]</field>
</ignore>

If you take a look at the rest of the map file, you'll also see:

<ignore>
    <datatype>[tablename].[field_name]</datatype>
</ignore>

Which also corresponds to a couple of errors in your screenshot.

Then unfortunately you're probably going to have to try the migration again and again until you're spot on. So if you have a standard Magento 2 install in a local database, simply run:

  • php bin/magento setup:uninstall (should drop your database)
  • php bin/magento setup:install (your install script)

Then go ahead and run your migrations again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.