0

This is a very critical issue.

I recently upgraded from Magento CE 2.2.5 to CE 2.2.6 using the Web Setup Wizard.

The upgrade went fine and the site is working.

When I try to access Web Setup Wizard in 2.2.6, I get a 404 Not Found response.

404 Not Found

What I already tried:

  • I removed all files and contents from /var/
  • I cleaned Magento cache
  • I tried accessing the setup from a different browser
  • Tried solutions such as accessing through http and https and activated/deactivated HTTP Strict Transport Security
  • The Document Root points to /path/to/magento/ and not /path/to/magento/pub/

Please note that I have a test instance on a different machine, this one was upgraded to 2.2.6 using composer. On this instance, /setup/ is working fine.

Any suggestion?

  • You can track from here as my experience web setup wizard was not displaying in 2.2.5 and not even in after upgrade to 2.2.6. but if you fresh install to 2.2.6 then you will get this menu there. – Hitesh Oct 3 '18 at 10:59
  • Thanks for the reference. Web Setup Wizard in 2.2.5 was working fine for me, this problem occurred in 2.2.6. Unfortunately, a fresh install is not an option. – Braza Oct 4 '18 at 9:03
0

Try to create symlink:

ln -s /data/web/magento2/pub/setup /data/web/public/setup

remove it after upgrade

rm -rf /data/web/public/setup
  • There's no /setup in magento2/pub – Braza Oct 4 '18 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.