0

I have created nearly 10 new attributes under product attributes. Its added to attribute set as well.

But now, when I update the product information, the data is not getting saved. Instead, after the product shown successfully saved message, the field is kept empty.

As in the image attached below, the diamond weight is a new attribute. And value 12 is given. But not getting saved.

enter image description here

The following shows my php-info()

enter image description here

  • Hi please check you max_input_vars limit in php.ini this may be issue if is less then it does not save data try to increase it. – Charul Tyagi Oct 3 '18 at 10:30
  • @CharulTyagi Increased to 10,000 and still the issue is the same. – Jithin U. Ahmed Oct 3 '18 at 10:41
  • so when are trying to save then what error you are seeing any thing getting wrong when submitting data. – Charul Tyagi Oct 3 '18 at 10:48
  • @CharulTyagi, everything seems to be right and no errors are shown. But the value is not saved. – Jithin U. Ahmed Oct 3 '18 at 10:54
  • have to checked by phpinfo function that max_input_vars you know sometimes it does not effect. – Charul Tyagi Oct 3 '18 at 11:15
1

First of all confirm that the mode should be developer.

Then,

  1. clear var folder
  2. clear generated except .htaccess
  3. run php bin/magento setup:upgrade
  4. run php bin/magento indexer:reindex
  5. run php bin/magento setup:static-content:deploy -f
  6. run php bin/magento cache:flush

Please share the screenshot of error that is occurring.

If this solution is helpful please accept.

  • I have made changes to many design pages. Will the "run php bin/magento setup:static-content:deploy -f" comment replace all those changes? I had an issue like this before. That is why I am asking this. – Jithin U. Ahmed Oct 4 '18 at 10:52
  • Running static content deploy generates files in pub/static folder. Yes all design related changes resides in this folder, so running this command will refresh your css and other design related changes – Narendra Vyas Oct 4 '18 at 11:03
  • Are you still facing any error ? If so you should share screenshot, so that we may know what is the error. – Narendra Vyas Oct 4 '18 at 11:04
  • I am not able to run the page after running the above comments. Its showing 500 error. – Jithin U. Ahmed Oct 5 '18 at 10:43
  • 1
    500 issue can be related to permission also, please check once the permission – Narendra Vyas Oct 5 '18 at 11:48
0

Try to run those commends from root :-

php bin/magento indexer:reindex php bin/magento cache:flush.

  • When I did this, the whole server is now showing error. Both for frond end as well as admin panel. Please help. – Jithin U. Ahmed Oct 3 '18 at 10:57
  • When I tried refreshing the cache, its showing An error occurred while refreshing cache – Jithin U. Ahmed Oct 3 '18 at 10:59
  • can you please share the error ? – vikaskimt Oct 3 '18 at 11:13
  • Error is fixed. But this does not worked. – Jithin U. Ahmed Oct 6 '18 at 6:45
0

I was having the same problem and I moved the Custom Attribute to the "General" group and the values started showing up.

0

What I did to get this working was (Magento 2.3.2):

  1. Mark the product attribute as required setting "Values required" to "YES"
  2. Go to a product, add the attribute, select a value and save
  3. If you need the product attribute as optional go back to the attribute edit page and set Values required to "NO"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.