So I tried to backup my site after having some custom programming done to it.

And now the site i gone. I can't login to the back OR see the front.

Both home and admin login give error: Internal Server Error

File "/home/thirdcoa/domains/thirdcoastsigns.com/public_html/index.php" is writeable by group

suPHP 0.7.1

Please help!

  • Duplicate - known issue. Magento destroys your file/folder permissions without reason. Reset file/folder permissions: magento.stackexchange.com/questions/7460/… and stackoverflow.com/questions/14331207/… Jun 20, 2014 at 5:16
  • Thank you! That was it exactly. Not sure why I could not find this . . .but you just saved my bacon. Also, if changing php to "664" does not work, try 644 . ... because that was what worked for me. Don't assume trying one is the trick, try them both.
    – user9402
    Jun 20, 2014 at 11:45
  • Yes, it depends on what the server operator was trying to accomplish with SuExec/SuPHP/WHM. Some servers are totally locked down (usually shared) and others are let have a more open group access. However it works, php files must be able to execute, and 666 is world read/write which in standard security circles is verboten. Why Magento wrongheadedly does what it does is unknown, but indicates programmers running as root/admin when they create it and not taking into account that some of us want to run with increased security. Jun 21, 2014 at 1:42
  • Thanks! I wonder is you can look at what seems to be a related issue for me (forgive me, I'm a bit of a noob . . .) stackoverflow.com/questions/24337405/…
    – user9402
    Jun 21, 2014 at 1:54


Browse other questions tagged or ask your own question.