3

Things I've confirmed:

Site is on Ubuntu 13.10 server at /var/www/mysite.com/htdocs/

  1. Uncommented: /var/www/mysite.com/htdocs/.htaccess

    RewriteBase /

  2. Catalog URL Key = phones

  3. Desired URL for this category = http://mysite.com/phones.html

  4. Added the following in /etc/apache2/sites-enabled/000-default.conf:

    <VirtualHost *:80> ... <Directory /var/www/> AllowOverride All </Directory> </VirtualHost>

  5. Restarted apache

  6. Cleared Magento Cache

  7. Cleared Magento Indexing

  8. System -> Configuration -> Web -> Use Web Server Rewrites = Yes

  9. System -> Configuration -> Web -> Secure -> Use Secure URLs in Frontend = Yes

Tried adding the AllowOverride All directory code to /etc/apache2/sites-enabled/mysite.com.conf as well and the result is the same. I've tried <Directory /var/www/mysite.com/htdocs/> and <Directory /var/www/mysite.com/> along with the version I put above. No dice.

The only thing the options above does is remove index.php from the links paths and breaks all the links. Trying to use url http://mysite.com/index.php/phones.html still works, but has been removed from all links.

  • The same issue for me. I have no idea where to continue. Maybe when Magento tried to modify .htaccess, it wasn't writable? That makes no sense, since whatever I do in the file, it makes no difference. – Rápli András Jul 25 '14 at 20:26
  • 1
    Do you have a rewrite rule in your .htaccess file, like RewriteRule .* index.php [L]? – Maikel Koek Jan 5 '15 at 13:42
1

Have you checked that the Rewrite Mod is on inside of Apache?

Try this:

sudo a2enmod rewrite

sudo service apache restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.