After manually moving Magento 2.2.4 site to a Windows IIS server, the pages are blank. Only a few lines of HTML is loaded, and I can see in the body tag there is an incorrect static file path:


I believe this should be:


Any idea where the _view is coming from and what might be causing it?

Cache has been flushed, static files have been generated. I can see static files on the server in correct directories.

I know Magento 2 doesn't officially support Windows, but a fresh install of Magento 2 works fine on this same environment with some small edits.

  • Yes, it happen for Windows server
    – Amit Bera
    Oct 1, 2018 at 15:33
  • Do you know why? Freshly installed Magento 2 works fine on the same Windows server.
    – Jarxberg
    Oct 1, 2018 at 15:52

2 Answers 2


I had the same issue, and the underlying issue was that the theme wasn't registered properly. There was no entry in the theme database table for that theme. The best way to register it is through the app/etc/config.php file, see https://devdocs.magento.com/guides/v2.4/config-guide/prod/config-reference-configphp.html#themes. For example:

'themes' => [
  'frontend/Magento/luma' => [
    'parent_id' => 'Magento/blank',
    'theme_path' => 'Magento/luma',
    'theme_title' => 'Magento Luma',
    'is_featured' => '0',
    'area' => 'frontend',
    'type' => '0',
    'code' => 'Magento/luma'

Turns out it was likely a very persistent cache issue in our case. Not exactly sure what fixed it, but this sequence got it to work:

  • Deleted static files
  • Disabled static files signing
  • php bin\magento cache:clean
  • php bin\magento setup:upgrade
  • php bin\magento setup:static-content:deploy en_GB
  • Checked config file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.