2

Clean install of Magento 2. See there are 88 Extensions to update. when trying to update, get stuck on Step 1: Readiness Check.

The php version errors I understand, but how do I solve: "requires magento/framework 102.0.* -> no matching package found."

Check Component Dependency
We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/module-mysql-mq 100.3.0-beta2 -> satisfiable by magento/module-mysql-mq[100.3.0-beta2].
- magento/module-mysql-mq 100.3.0-beta2 requires magento/framework 102.0.* -> no matching package found.
Problem 2
- Installation request for magento/module-amqp 100.3.0-beta2 -> satisfiable by magento/module-amqp[100.3.0-beta2].
- magento/module-amqp 100.3.0-beta2 requires magento/framework 102.0.* -> no matching package found.
Problem 3
- Installation request for magento/module-grouped-product-sample-data 100.3.0-beta2 -> satisfiable by magento/module-grouped-product-sample-data[100.3.0-beta2].
- magento/module-grouped-product-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 4
- Installation request for magento/module-customer-sample-data 100.3.0-beta2 -> satisfiable by magento/module-customer-sample-data[100.3.0-beta2].
- magento/module-customer-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 5
- Installation request for magento/module-downloadable-sample-data 100.3.0-beta2 -> satisfiable by magento/module-downloadable-sample-data[100.3.0-beta2].
- magento/module-downloadable-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 6
- Installation request for magento/module-offline-shipping-sample-data 100.3.0-beta2 -> satisfiable by magento/module-offline-shipping-sample-data[100.3.0-beta2].
- magento/module-offline-shipping-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 7
- Installation request for magento/module-theme-sample-data 100.3.0-beta2 -> satisfiable by magento/module-theme-sample-data[100.3.0-beta2].
- magento/module-theme-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 8
- Installation request for magento/module-sales-sample-data 100.3.0-beta2 -> satisfiable by magento/module-sales-sample-data[100.3.0-beta2].
- magento/module-sales-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 9
- Installation request for magento/module-product-links-sample-data 100.3.0-beta2 -> satisfiable by magento/module-product-links-sample-data[100.3.0-beta2].
- magento/module-product-links-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 10
- Installation request for magento/module-configurable-sample-data 100.3.0-beta2 -> satisfiable by magento/module-configurable-sample-data[100.3.0-beta2].
- magento/module-configurable-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 11
- Installation request for magento/module-sales-rule-sample-data 100.3.0-beta2 -> satisfiable by magento/module-sales-rule-sample-data[100.3.0-beta2].
- magento/module-sales-rule-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 12
- Installation request for magento/module-swatches-sample-data 100.3.0-beta2 -> satisfiable by magento/module-swatches-sample-data[100.3.0-beta2].
- magento/module-swatches-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 13
- Installation request for magento/module-wishlist-sample-data 100.3.0-beta2 -> satisfiable by magento/module-wishlist-sample-data[100.3.0-beta2].
- magento/module-wishlist-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 14
- Installation request for magento/module-bundle-sample-data 100.3.0-beta2 -> satisfiable by magento/module-bundle-sample-data[100.3.0-beta2].
- magento/module-bundle-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 15
- Installation request for magento/module-widget-sample-data 100.3.0-beta2 -> satisfiable by magento/module-widget-sample-data[100.3.0-beta2].
- magento/module-widget-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 16
- Installation request for magento/module-catalog-rule-sample-data 100.3.0-beta2 -> satisfiable by magento/module-catalog-rule-sample-data[100.3.0-beta2].
- magento/module-catalog-rule-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 17
- Installation request for magento/module-msrp-sample-data 100.3.0-beta2 -> satisfiable by magento/module-msrp-sample-data[100.3.0-beta2].
- magento/module-msrp-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 18
- Installation request for magento/module-review-sample-data 100.3.0-beta2 -> satisfiable by magento/module-review-sample-data[100.3.0-beta2].
- magento/module-review-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 19
- Installation request for magento/module-tax-sample-data 100.3.0-beta2 -> satisfiable by magento/module-tax-sample-data[100.3.0-beta2].
- magento/module-tax-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 20
- Installation request for magento/module-cms-sample-data 100.3.0-beta2 -> satisfiable by magento/module-cms-sample-data[100.3.0-beta2].
- magento/module-cms-sample-data 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 21
- Installation request for magento/module-elasticsearch 100.3.0-beta2 -> satisfiable by magento/module-elasticsearch[100.3.0-beta2].
- magento/module-elasticsearch 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 22
- Installation request for magento/module-asynchronous-operations 100.3.0-beta2 -> satisfiable by magento/module-asynchronous-operations[100.3.0-beta2].
- magento/module-asynchronous-operations 100.3.0-beta2 requires magento/framework 102.0.* -> no matching package found.
Problem 23
- Installation request for magento/module-shared-catalog 100.0.6 -> satisfiable by magento/module-shared-catalog[100.0.6].
- magento/module-shared-catalog 100.0.6 requires magento/module-asynchronous-operations 100.2.* -> satisfiable by magento/module-asynchronous-operations[100.2.0-rc20, 100.2.0-rc21, 100.2.0-rc22, 100.2.0-rc23, 100.2.0-rc30, 100.2.0, 100.2.1, 100.2.2] but these conflict with your requirements or minimum-stability.
Problem 24
- Installation request for magento/inventory-composer-metapackage 1.0.0-beta2 -> satisfiable by magento/inventory-composer-metapackage[1.0.0-beta2].
- magento/inventory-composer-metapackage 1.0.0-beta2 requires magento/inventory-composer-installer 1.0.0-beta -> no matching package found.
Problem 25
- Installation request for magento/module-inventory-source-selection-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-source-selection-api[1.0.0-beta2].
- magento/module-inventory-source-selection-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 26
- Installation request for magento/module-inventory-source-selection 1.0.0-beta2 -> satisfiable by magento/module-inventory-source-selection[1.0.0-beta2].
- magento/module-inventory-source-selection 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 27
- Installation request for magento/module-inventory-shipping-admin-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-shipping-admin-ui[1.0.0-beta2].
- magento/module-inventory-shipping-admin-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 28
- Installation request for magento/module-inventory-shipping 1.0.0-beta2 -> satisfiable by magento/module-inventory-shipping[1.0.0-beta2].
- magento/module-inventory-shipping 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 29
- Installation request for magento/module-inventory-sales-frontend-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-sales-frontend-ui[1.0.0-beta2].
- magento/module-inventory-sales-frontend-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 30
- Installation request for magento/module-inventory-sales-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-sales-api[1.0.0-beta2].
- magento/module-inventory-sales-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 31
- Installation request for magento/module-inventory-sales-admin-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-sales-admin-ui[1.0.0-beta2].
- magento/module-inventory-sales-admin-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 32
- Installation request for magento/module-inventory-sales 1.0.0-beta2 -> satisfiable by magento/module-inventory-sales[1.0.0-beta2].
- magento/module-inventory-sales 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 33
- Installation request for magento/module-inventory-reservations-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-reservations-api[1.0.0-beta2].
- magento/module-inventory-reservations-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 34
- Installation request for magento/module-inventory-reservations 1.0.0-beta2 -> satisfiable by magento/module-inventory-reservations[1.0.0-beta2].
- magento/module-inventory-reservations 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 35
- Installation request for magento/module-inventory-product-alert 1.0.0-beta2 -> satisfiable by magento/module-inventory-product-alert[1.0.0-beta2].
- magento/module-inventory-product-alert 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 36
- Installation request for magento/module-inventory-multi-dimensional-indexer-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-multi-dimensional-indexer-api[1.0.0-beta2].
- magento/module-inventory-multi-dimensional-indexer-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 37
- Installation request for magento/module-inventory-low-quantity-notification-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-low-quantity-notification-api[1.0.0-beta2].
- magento/module-inventory-low-quantity-notification-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 38
- Installation request for magento/module-inventory-low-quantity-notification-admin-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-low-quantity-notification-admin-ui[1.0.0-beta2].
- magento/module-inventory-low-quantity-notification-admin-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 39
- Installation request for magento/module-inventory-low-quantity-notification 1.0.0-beta2 -> satisfiable by magento/module-inventory-low-quantity-notification[1.0.0-beta2].
- magento/module-inventory-low-quantity-notification 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 40
- Installation request for magento/module-inventory-indexer 1.0.0-beta2 -> satisfiable by magento/module-inventory-indexer[1.0.0-beta2].
- magento/module-inventory-indexer 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 41
- Installation request for magento/module-inventory-import-export 1.0.0-beta2 -> satisfiable by magento/module-inventory-import-export[1.0.0-beta2].
- magento/module-inventory-import-export 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 42
- Installation request for magento/module-inventory-grouped-product 1.0.0-beta2 -> satisfiable by magento/module-inventory-grouped-product[1.0.0-beta2].
- magento/module-inventory-grouped-product 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 43
- Installation request for magento/module-inventory-configuration-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-configuration-api[1.0.0-beta2].
- magento/module-inventory-configuration-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 44
- Installation request for magento/module-inventory-configuration 1.0.0-beta2 -> satisfiable by magento/module-inventory-configuration[1.0.0-beta2].
- magento/module-inventory-configuration 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 45
- Installation request for magento/module-inventory-configurable-product-indexer 1.0.0-beta2 -> satisfiable by magento/module-inventory-configurable-product-indexer[1.0.0-beta2].
- magento/module-inventory-configurable-product-indexer 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 46
- Installation request for magento/module-inventory-configurable-product-admin-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-configurable-product-admin-ui[1.0.0-beta2].
- magento/module-inventory-configurable-product-admin-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 47
- Installation request for magento/module-inventory-configurable-product 1.0.0-beta2 -> satisfiable by magento/module-inventory-configurable-product[1.0.0-beta2].
- magento/module-inventory-configurable-product 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 48
- Installation request for magento/module-inventory-catalog-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-catalog-api[1.0.0-beta2].
- magento/module-inventory-catalog-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 49
- Installation request for magento/module-inventory-catalog-admin-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-catalog-admin-ui[1.0.0-beta2].
- magento/module-inventory-catalog-admin-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 50
- Installation request for magento/module-inventory-catalog 1.0.0-beta2 -> satisfiable by magento/module-inventory-catalog[1.0.0-beta2].
- magento/module-inventory-catalog 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 51
- Installation request for magento/module-inventory-bundle-product 1.0.0-beta2 -> satisfiable by magento/module-inventory-bundle-product[1.0.0-beta2].
- magento/module-inventory-bundle-product 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 52
- Installation request for magento/module-inventory-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-api[1.0.0-beta2].
- magento/module-inventory-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 53
- Installation request for magento/module-inventory-admin-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-admin-ui[1.0.0-beta2].
- magento/module-inventory-admin-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 54
- Installation request for magento/module-inventory 1.0.0-beta2 -> satisfiable by magento/module-inventory[1.0.0-beta2].
- magento/module-inventory 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 55
- Installation request for magento/module-inventory-cache 1.0.0-beta2 -> satisfiable by magento/module-inventory-cache[1.0.0-beta2].
- magento/module-inventory-cache 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 56
- Installation request for magento/module-inventory-catalog-search 1.0.0-beta2 -> satisfiable by magento/module-inventory-catalog-search[1.0.0-beta2].
- magento/module-inventory-catalog-search 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 57
- Installation request for magento/module-bundle-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-bundle-graph-ql[100.3.0-beta2].
- magento/module-bundle-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 58
- Installation request for magento/module-catalog-url-rewrite-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-catalog-url-rewrite-graph-ql[100.3.0-beta2].
- magento/module-catalog-url-rewrite-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 59
- Installation request for magento/module-configurable-product-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-configurable-product-graph-ql[100.3.0-beta2].
- magento/module-configurable-product-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 60
- Installation request for magento/module-downloadable-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-downloadable-graph-ql[100.3.0-beta2].
- magento/module-downloadable-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 61
- Installation request for magento/module-grouped-product-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-grouped-product-graph-ql[100.3.0-beta2].
- magento/module-grouped-product-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 62
- Installation request for magento/module-store-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-store-graph-ql[100.3.0-beta2].
- magento/module-store-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 63
- Installation request for magento/module-tax-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-tax-graph-ql[100.3.0-beta2].
- magento/module-tax-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 64
- Installation request for magento/module-weee-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-weee-graph-ql[100.3.0-beta2].
- magento/module-weee-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 65
- Installation request for magento/module-catalog-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-catalog-graph-ql[100.3.0-beta2].
- magento/module-catalog-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 66
- Installation request for magento/module-cms-url-rewrite-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-cms-url-rewrite-graph-ql[100.3.0-beta2].
- magento/module-cms-url-rewrite-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 67
- Installation request for magento/module-customer-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-customer-graph-ql[100.3.0-beta2].
- magento/module-customer-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 68
- Installation request for magento/module-eav-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-eav-graph-ql[100.3.0-beta2].
- magento/module-eav-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 69
- Installation request for magento/module-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-graph-ql[100.3.0-beta2].
- magento/module-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 70
- Installation request for magento/module-swagger-webapi-async 100.3.0-beta2 -> satisfiable by magento/module-swagger-webapi-async[100.3.0-beta2].
- magento/module-swagger-webapi-async 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 71
- Installation request for magento/module-swatches-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-swatches-graph-ql[100.3.0-beta2].
- magento/module-swatches-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 72
- Installation request for magento/module-tinymce-3 100.3.0-beta2 -> satisfiable by magento/module-tinymce-3[100.3.0-beta2].
- magento/module-tinymce-3 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 73
- Installation request for magento/module-url-rewrite-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-url-rewrite-graph-ql[100.3.0-beta2].
- magento/module-url-rewrite-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 74
- Installation request for magento/module-webapi-async 100.3.0-beta2 -> satisfiable by magento/module-webapi-async[100.3.0-beta2].
- magento/module-webapi-async 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 75
- Installation request for magento/module-catalog-inventory-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-catalog-inventory-graph-ql[100.3.0-beta2].
- magento/module-catalog-inventory-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 76
- Installation request for magento/module-cms-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-cms-graph-ql[100.3.0-beta2].
- magento/module-cms-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 77
- Installation request for magento/module-quote-graph-ql 100.3.0-beta2 -> satisfiable by magento/module-quote-graph-ql[100.3.0-beta2].
- magento/module-quote-graph-ql 100.3.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 78
- Installation request for magento/module-inventory-grouped-product-admin-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-grouped-product-admin-ui[1.0.0-beta2].
- magento/module-inventory-grouped-product-admin-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 79
- Installation request for magento/module-inventory-grouped-product-indexer 1.0.0-beta2 -> satisfiable by magento/module-inventory-grouped-product-indexer[1.0.0-beta2].
- magento/module-inventory-grouped-product-indexer 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 80
- Installation request for magento/module-inventory-source-deduction-api 1.0.0-beta2 -> satisfiable by magento/module-inventory-source-deduction-api[1.0.0-beta2].
- magento/module-inventory-source-deduction-api 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 81
- Installation request for magento/module-inventory-bundle-product-admin-ui 1.0.0-beta2 -> satisfiable by magento/module-inventory-bundle-product-admin-ui[1.0.0-beta2].
- magento/module-inventory-bundle-product-admin-ui 1.0.0-beta2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
Problem 82
- amzn/amazon-pay-and-login-with-amazon-core-module 2.1.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.30) does not satisfy that requirement.
- amzn/amazon-pay-and-login-magento-2-module 2.1.1 requires amzn/amazon-pay-and-login-with-amazon-core-module 2.1.1 -> satisfiable by amzn/amazon-pay-and-login-with-amazon-core-module[2.1.1].
- Installation request for amzn/amazon-pay-and-login-magento-2-module 2.1.1 -> satisfiable by amzn/amazon-pay-and-login-magento-2-module[2.1.1].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

For additional assistance, see component dependency help .
  • Try this command php -d memory_limit=-1 /usr/local/bin/composer update --ignore-platform-reqs – Ylgen Guxholli Sep 28 '18 at 11:30
  • Thanks, but no change in the errors after running this – Justine Rebecca Schulz Sep 28 '18 at 11:59
  • Beta versions usually have problems on updating , when you work on clean magento try to use magento versions that are released ,not versions like alpha and beta because the content of theirs changes often . – Ylgen Guxholli Sep 28 '18 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.