I'm trying to update from to

I tried to update from Magento Connect and by ./mage scripts.
Then I found this roadmap and today morning I also tried this way.

By all the ways, when I call the URL of my site I get immediately a blank page and this error in the apache log:

PHP Fatal error:  Call to a member function getAllOptions() on a non-object in /home/MYSITE/19_www/app/code/core/Mage/Core/Model/Cache.php on line 478

Searching the web someone speak about a problem with Aitoc extensions which should be updated. This could be my case so in the morning I also try to delete all Aitoc and AdjustWare modules by removing folders in /app/code/... and removing xml files from /app/etc/modules.
After that I get this error:

PHP Fatal error:  Class 'Aitoc_Aitsys_Model_Rewriter_Autoload' not found in /home/MYSITE/19_www/app/code/local/Mage/Core/Model/App.php on line 6

So It seems that Aitoc modules are anyway loaded or requested.

Could someone help me?

  • Have you cleared cache? Commented Jun 19, 2014 at 13:30
  • clear cache and check Commented Jun 19, 2014 at 13:32
  • With the last attempt (following the roadmap) the var/cache is not created yet. Commented Jun 19, 2014 at 13:34
  • What does your local.xml look like? Standard? Commented Jun 19, 2014 at 13:57
  • @DouglasRadburn the local.xml is standard. Commented Jun 19, 2014 at 14:09

3 Answers 3


It appears that you have local copies of core files which will make it tough to upgrade. app/code/local/Mage/Core/Model/App.php is mentioned in one of the error messages that you have posted.

What I would suggest is check all the local core files so that you know what modifications you have made and why. Make a note of these as you will need to re-make these changes later on. Then simply remove all the files under /code/local/Mage then you should have a "clean" install of 1.9 that is working, if all extensions install are compatibly.

After you have a clean version of 1.9 then I would suggest re-making all the modifications you have made under local, but try to use rewrites and events where possible rather the coping the complete file under the local code pool.


If you go to your app/etc/modules directory and rename any of the xml files that have to do with AITOC you will find that your error will stop. I would then recommend not using AITOC as their re-writes usually cause havoc on websites.

I will open just backup my xml to a different directory for testing, then move them back one at a time to confirm that you have found the correct one.

Aitoc will also write to you var directory and you need to make sure it is writable and of course clear you cache!


Here is the way to fix it (It worked for me after lot of research):

chmod 644 app/etc/config.xml
chmod 755 app/etc
chmod 755 app/etc/modules

rm -rf var/cache/* var/session/*
php shell/indexer.php --reindexall

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.