1

I enabled Template Path Hints for Storefront, though magento administration panel. Then, I tried to disable them, but they are stuck in enabled mode.

I have also tried the following:

  • php bin/magento dev:template-hints:disable
  • php bin/magento cache:clean
  • php bin/magento cache:flush

Path hints are always enabled.

ps. the setting is disabled in all store views

  • Any error warning generate in system.log? – Rohan Hapani Sep 24 '18 at 8:34
  • go to admin backend: Store > Configuration > Advanced > Developer > Debug > Enabled Template Path Hints for Storefront > Yes – Aditya Shah Sep 24 '18 at 9:21
0

Try the following check/tasks to disable the template hints:

1) Go into the database and look for all records in "core_config_data" with the path 'dev/debug/template_hints_storefront'. They should all be set to '0' as value.

2) Remove content from folders:

  • /generated/
  • /var/
  • /pub/static/

3) php bin/magento cache:flush

4) Run site

  • I will accept your answer as a solution, cause I did'nt finally foind what was the reason for this. After some time, the problem was solved without me doing anything. I guess that this is one of the many things magento2 drives us to madness. – zekia Sep 27 '18 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.