2

I have tried through the Magento connect manager but it always ends with Nginx proxy 504

enter image description here

Also tried with

chmod +x mage
./mage mage-setup .
./mage config-set preferred_state stable
./mage sync
./mage install https://connect20.magentocommerce.com/community Mage_All_Latest --force

but I get following output with some errors and seems to not upgrade to latest version

$ chmod +x mage
$ ./mage mage-setup .
Running initial setup...
Success
Success
Error: 
channel-add: Channel 'community' already exist!
$ ./mage mage-setup .
Running initial setup...
Success
Success
Successfully added: http://connect20.magentocommerce.com/community
$ ./mage config-set preferred_state stable
Success
$ ./mage sync
Successfully added: community/Activo_CatalogSearch-1.1.0
Successfully added: community/Cm_RedisSession-1.9.3.0
Successfully added: community/Interface_Adminhtml_Default-1.9.3.0
Successfully added: community/Interface_Frontend_Base_Default-1.9.3.0
Successfully added: community/Interface_Frontend_Default-1.9.3.0
Successfully added: community/Interface_Frontend_Rwd_Default-1.9.3.0
Successfully added: community/Interface_Install_Default-1.9.3.0
Successfully added: community/Lib_Cm-1.9.3.0
Successfully added: community/Lib_Credis-1.9.3.0
Successfully added: community/Lib_Google_Checkout-1.9.3.0
Successfully added: community/Lib_IDNA2-1.9.3.0
Successfully added: community/Lib_Js_Calendar-1.51.1.6
Successfully added: community/Lib_Js_Ext-1.9.3.0
Successfully added: community/Lib_Js_Mage-1.9.3.0
Successfully added: community/Lib_Js_Prototype-1.9.3.0
Successfully added: community/Lib_Js_TinyMCE-3.5.11.5
Successfully added: community/Lib_LinLibertineFont-2.8.14.6
Successfully added: community/Lib_Mage-1.9.3.0
Successfully added: community/Lib_Magento-1.9.3.0
Successfully added: community/Lib_Pelago-1.9.3.0
Successfully added: community/Lib_Phpseclib-1.9.3.0
Successfully added: community/Lib_Unserialize-1.9.3.0
Successfully added: community/Lib_Varien-1.9.3.0
Successfully added: community/Lib_ZF-1.12.10.5
Successfully added: community/Lib_ZF_Locale-1.12.10.5
Successfully added: community/Locale_Mage_community_it_IT-1.9.2.1.1
Successfully added: community/Mage_All_Latest-1.9.3.0
Successfully added: community/Mage_Centinel-1.9.3.0
Successfully added: community/Mage_Compiler-1.9.3.0
Successfully added: community/Mage_Core_Adminhtml-1.9.3.0
Successfully added: community/Mage_Core_Modules-1.9.3.0
Successfully added: community/Mage_Downloader-1.9.3.0
Successfully added: community/Mage_Locale_en_US-1.9.3.0
Successfully added: community/Magento_Mobile-1.9.3.0
Successfully added: community/Phoenix_Moneybookers-1.9.3.0
Successfully added: community/Sitewards_B2BProfessional-3.0.5
$ ./mage install https://connect20.magentocommerce.com/community Mage_All_Latest --force
PHP Warning:  scandir(/var/www/vhosts/domain.com/httpdocs/./errors): failed to open dir: No such file or directory in /var/www/vhosts/domain.com/httpdocs/downloader/lib/Mage/Connect/Packager.php on line 243
PHP Warning:  scandir(): (errno 2): No such file or directory in /var/www/vhosts/domain.com/httpdocs/downloader/lib/Mage/Connect/Packager.php on line 243
Checking dependencies of packages
Error: 
install: Failed to delete files: /var/www/vhosts/domain.com/httpdocs/./pkginfo/Mage_All_Latest.txt 
 Check permissions
Error: 
install: Package community/Interface_Adminhtml_Default 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Interface_Adminhtml_Default 1.9.3.0
Package community/Interface_Adminhtml_Default 1.9.3.0 installed successfully
Error: 
install: Package community/Interface_Frontend_Default 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Interface_Frontend_Default 1.9.3.0
Package community/Interface_Frontend_Default 1.9.3.0 installed successfully
Error: 
install: Package community/Interface_Install_Default 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Interface_Install_Default 1.9.3.0
Package community/Interface_Install_Default 1.9.3.0 installed successfully
Error: 
install: Package community/Mage_Downloader 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Mage_Downloader 1.9.3.0
Package community/Mage_Downloader 1.9.3.0 installed successfully
Error: 
install: Package community/Mage_Centinel 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Mage_Centinel 1.9.3.0
Package community/Mage_Centinel 1.9.3.0 installed successfully
Error: 
install: Package community/Interface_Frontend_Base_Default 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Interface_Frontend_Base_Default 1.9.3.0
Package community/Interface_Frontend_Base_Default 1.9.3.0 installed successfully
Error: 
install: Package community/Phoenix_Moneybookers 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Phoenix_Moneybookers 1.9.3.0
Package community/Phoenix_Moneybookers 1.9.3.0 installed successfully
Error: 
install: Package community/Mage_Compiler 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Mage_Compiler 1.9.3.0
Package community/Mage_Compiler 1.9.3.0 installed successfully
Error: 
install: Package community/Magento_Mobile 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Magento_Mobile 1.9.3.0
Package community/Magento_Mobile 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Cm 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Cm 1.9.3.0
Package community/Lib_Cm 1.9.3.0 installed successfully
Error: 
install: Package community/Cm_RedisSession 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Cm_RedisSession 1.9.3.0
Package community/Cm_RedisSession 1.9.3.0 installed successfully
Error: 
install: Package community/Interface_Frontend_Rwd_Default 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Interface_Frontend_Rwd_Default 1.9.3.0
Package community/Interface_Frontend_Rwd_Default 1.9.3.0 installed successfully
Error: 
install: Package community/Mage_Core_Adminhtml 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Mage_Core_Adminhtml 1.9.3.0
Package community/Mage_Core_Adminhtml 1.9.3.0 installed successfully
Error: 
install: Package community/Mage_Core_Modules 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Mage_Core_Modules 1.9.3.0
Package community/Mage_Core_Modules 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Js_Ext 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Js_Ext 1.9.3.0
Package community/Lib_Js_Ext 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_LinLibertineFont 2.8.14.6: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_LinLibertineFont 2.8.14.6
Package community/Lib_LinLibertineFont 2.8.14.6 installed successfully
Error: 
install: Package community/Lib_Js_TinyMCE 3.5.11.5: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Js_TinyMCE 3.5.11.5
Package community/Lib_Js_TinyMCE 3.5.11.5 installed successfully
Error: 
install: Package community/Lib_Varien 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Varien 1.9.3.0
Package community/Lib_Varien 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Google_Checkout 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Google_Checkout 1.9.3.0
Package community/Lib_Google_Checkout 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Js_Calendar 1.51.1.6: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Js_Calendar 1.51.1.6
Package community/Lib_Js_Calendar 1.51.1.6 installed successfully
Error: 
install: Package community/Lib_Js_Mage 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Js_Mage 1.9.3.0
Package community/Lib_Js_Mage 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Phpseclib 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Phpseclib 1.9.3.0
Package community/Lib_Phpseclib 1.9.3.0 installed successfully
Error: 
install: Package community/Mage_Locale_en_US 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Mage_Locale_en_US 1.9.3.0
Package community/Mage_Locale_en_US 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Mage 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Mage 1.9.3.0
Package community/Lib_Mage 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Magento 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Magento 1.9.3.0
Package community/Lib_Magento 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Credis 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Credis 1.9.3.0
Package community/Lib_Credis 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Pelago 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Pelago 1.9.3.0
Package community/Lib_Pelago 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_Unserialize 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Unserialize 1.9.3.0
Package community/Lib_Unserialize 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_IDNA2 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_IDNA2 1.9.3.0
Package community/Lib_IDNA2 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_ZF 1.12.10.5: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_ZF 1.12.10.5
Package community/Lib_ZF 1.12.10.5 installed successfully
Error: 
install: Package community/Lib_Js_Prototype 1.9.3.0: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_Js_Prototype 1.9.3.0
Package community/Lib_Js_Prototype 1.9.3.0 installed successfully
Error: 
install: Package community/Lib_ZF_Locale 1.12.10.5: requires PHP version  >= 5.2.0 and <= 6.0.0  current is: 7.1.22
Installing package community/Lib_ZF_Locale 1.12.10.5
Package community/Lib_ZF_Locale 1.12.10.5 installed successfully
Package installed: community/Interface_Adminhtml_Default 1.9.3.0
Package installed: community/Interface_Frontend_Default 1.9.3.0
Package installed: community/Interface_Install_Default 1.9.3.0
Package installed: community/Mage_Downloader 1.9.3.0
Package installed: community/Mage_Centinel 1.9.3.0
Package installed: community/Interface_Frontend_Base_Default 1.9.3.0
Package installed: community/Phoenix_Moneybookers 1.9.3.0
Package installed: community/Mage_Compiler 1.9.3.0
Package installed: community/Magento_Mobile 1.9.3.0
Package installed: community/Lib_Cm 1.9.3.0
Package installed: community/Cm_RedisSession 1.9.3.0
Package installed: community/Interface_Frontend_Rwd_Default 1.9.3.0
Package installed: community/Mage_Core_Adminhtml 1.9.3.0
Package installed: community/Mage_Core_Modules 1.9.3.0
Package installed: community/Lib_Js_Ext 1.9.3.0
Package installed: community/Lib_LinLibertineFont 2.8.14.6
Package installed: community/Lib_Js_TinyMCE 3.5.11.5
Package installed: community/Lib_Varien 1.9.3.0
Package installed: community/Lib_Google_Checkout 1.9.3.0
Package installed: community/Lib_Js_Calendar 1.51.1.6
Package installed: community/Lib_Js_Mage 1.9.3.0
Package installed: community/Lib_Phpseclib 1.9.3.0
Package installed: community/Mage_Locale_en_US 1.9.3.0
Package installed: community/Lib_Mage 1.9.3.0
Package installed: community/Lib_Magento 1.9.3.0
Package installed: community/Lib_Credis 1.9.3.0
Package installed: community/Lib_Pelago 1.9.3.0
Package installed: community/Lib_Unserialize 1.9.3.0
Package installed: community/Lib_IDNA2 1.9.3.0
Package installed: community/Lib_ZF 1.12.10.5
Package installed: community/Lib_Js_Prototype 1.9.3.0
Package installed: community/Lib_ZF_Locale 1.12.10.5

NOTE the site has been working and has updated succesfully from 1.8.x upwards a few times and all this time php 7 was running

I have setup so that php 5.6 the default php used with alias

alias php='/usr/bin/php5.6'

and made sure php -v gives php 5.6 but to no avail

1

Well, at least through Magento Connect you should choose either update Mage_All_Latest, which contains the full update, or choose below what to update individually. From your screenshot I see you choose both Mage_All_Latest and the individual options. This leads to a lot of compatibility errors that take a long time to appear....maybe this causes your error?

0

What i did to install this update through Magento Connect

I changed the php version to 5.6 and after updating "Mage_All_Latest" i changed php back to 7.1. That worked for me.

0

Download magento 1.9.3.10 And unpack zip. Copy all files to your magento folder with replacing old files , but then you will replacing them , check for safe (check updates) .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.