3

All my automated sales emails (like order confirmation, shipment...etc ) are sent from [email protected],

I want emails to be sent from my Magento domain exemple: [email protected]

thank You.

2
  • What's your email setup in magento backend?
    – BartZalas
    Commented Sep 21, 2018 at 22:43
  • what you mean by email setup explain please ? , in Magento backend all emails are set to @mydomain.com
    – SoCix
    Commented Sep 23, 2018 at 16:58

2 Answers 2

1

You can configure them at :

Store > Settings > Configuration > Sales > Sales Email

2
  • in Magento backend all emails are set to @mydomain.com but emails are sent from my hosting domain
    – SoCix
    Commented Sep 23, 2018 at 17:10
  • Please have a check with server settings in that case, sometimes it being reset from there. Commented Sep 24, 2018 at 5:15
1

It looks like more people have this problem:

Temp solution add this to your php.ini (I checked this now and its works for me)

sendmail_path= "/usr/sbin/sendmail -f [email protected] -F 'Your SHOP <[email protected]>' -t

or disable amazon pay.

More:

https://github.com/magento/magento2/issues/14952

Magento 2 Order / Shipment Emails From Address Suddenly Apache / apache@localhost

1
  • Thanks for the comment, I tried this but still not working,
    – SoCix
    Commented Oct 1, 2018 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.