0

I just installed a new theme and after clearing hte cache when i tried to login to the admin,it is showing blank page. Further debugging lead to the following:

exception 'Mage_Core_Exception' with message 'Invalid block type:W3Themes_Themeoptions_Block_Adminhtml_Page_Menu' in /var/www/demo.xyz.com/app/Mage.php:563
Stack trace: > #0 /var/www/demo.xyz.com/includes/src/Mage_Core_Model_Layout.php(469): Mage::throwException('Invalid block t...')
#1 /var/www/demo.xyz.com/app/code/local/Aitoc/Aitsys/Model/Core/Layout.php(10): Mage_Core_Model_Layout->getBlockInstance('adminhtml/page...', Array)
#2 /var/www/demo.xyz.com/includes/src/Mage_Core_Model_Layout.php(411): Aitoc_Aitsys_Model_Core_Layout->getBlockInstance('adminhtml/page...', Array)
#3 /var/www/demo.xyz.com/includes/src/Mage_Core_Model_Layout.php(446): Mage_Core_Model_Layout->createBlock('adminhtml/page_...', 'menu')
#4 /var/www/demo.xyz.com/includes/src/Mage_Core_Model_Layout.php(238): Mage_Core_Model_Layout->addBlock('adminhtml/page_...', 'menu')
#5 /var/www/demo.xyz.com/includes/src/Mage_Core_Model_Layout.php(204): Mage_Core_Model_Layout->_generateBlock(Object(Mage_Core_Model_Layout_Element), Object(Mage_Core_Model_Layout_Element))
#6 /var/www/demo.xyz.com/includes/src/Mage_Core_Model_Layout.php(205): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))
#7 /var/www/demo.xyz.com/includes /src/Mage_Core_Controller_Varien_Action.php(345): Mage_Core_Model_Layout->generateBlocks()
#8 /var/www/demo.xyz.com/includes /src/Mage_Core_Controller_Varien_Action.php(270): Mage_Core_Controller_Varien_Action->generateLayoutBlocks()
#9 /var/www/demo.xyz.com/includes/src/Mage_Adminhtml_Controller_Action.php(263): Mage_Core_Controller_Varien_Action->loadLayout(NULL, true, true)
#10 /var/www/demo.xyz.com/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(91): Mage_Adminhtml_Controller_Action->loadLayout()
#11 /var/www/demo.xyz.com/includes/src/Mage_Core_Controller_Varien_Action.php(420): Mage_Adminhtml_System_ConfigController->editAction()
#12 /var/www/demo.xyz.com/includes/src/Mage_Core_Controller_Varien_Router_Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('edit')
#13 /var/www/demo.xyz.com/includes/src/Mage_Core_Controller_Varien_Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#14 /var/www/demo.xyz.com/app/code/core/Mage/Core/Model/App.php(347): Mage_Core_Controller_Varien_Front->dispatch()
#15 /var/www/demo.xyz.com/app/Mage.php(640): Mage_Core_Model_App->run(Array)
#16 /var/www/demo.xyz.com/index.php(98): Mage::run('', 'store')
#17 {main}

  • This question appears to be off-topic because it is about a third party module support. – Marius Jun 18 '14 at 15:40
  • @Marius : The theme provider is not providing support. So this is the only place where i can get some help. – Vishal Jun 18 '14 at 15:45
1

Problem:

W3Themes_Themeoptions_Block_Adminhtml_Page_Menu

obviously this class doesn't exist.

  • :What should i do then? – Vishal Jun 18 '14 at 15:21
  • Before this i had following problem : Warning: include(W3Themes_Upsellslider_Model_Layout_Generate_Observer.php): failed to open stream: No such file or directory in /var/www/demo.xyz.com/includes/src/Varien_Autoload.php on line 93 So i disabled the xml file of this module. iS it correct aproach? – Vishal Jun 18 '14 at 15:23
  • That warning means you are missing a file. It should be in your zipfile in magma_package_1.4/magma_template_for_magento_1.8.zip/app/code/local/W3Themes/Upsellslider/Model/Layout/Generate/Observer.php. Once you added that file, re-enable the module. – Jory Geerts Jun 19 '14 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.