6

Only when trying to change a customer's password from admin, I get this error...

Fatal error: Uncaught Error: Call to a member function getBackend() on boolean in /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Eav/Model/Entity/Abstract.php:1553 Stack trace: 

#0 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Customer/Model/Resource/Customer.php(240): Mage_Eav_Model_Entity_Abstract->saveAttribute(Object(Magestore_Onestepcheckout_Model_Customer_Customer), 'password_create...') 

#1 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Customer/Model/Customer.php(239): Mage_Customer_Model_Resource_Customer->changePassword(Object(Magestore_Onestepcheckout_Model_Customer_Customer), '@3_VZHAf') 

#2 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Adminhtml/controllers/CustomerController.php(367): Mage_Customer_Model_Customer->changePassword('@3_VZHAf') 

#3 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_CustomerController->saveAction() 

#4 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Core/Controll in /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Eav/Model/Entity/Abstract.php on line 1553

I have no custom attributes so not sure why its trying to save attributes when I'm just trying to update the customer's password... if I update anything else it works fine.

The front end is doing the same thing...

Error from forgot your password on the front end...

Fatal error: Uncaught Error: Call to a member function getBackend() on boolean in /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Eav/Model/Entity/Abstract.php:1553 Stack trace: #0 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Customer/Model/Resource/Customer.php(353): Mage_Eav_Model_Entity_Abstract->saveAttribute(Object(Magestore_Onestepcheckout_Model_Customer_Customer), 'rp_customer_id') #1 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Customer/Model/Customer.php(1412): Mage_Customer_Model_Resource_Customer->changeResetPasswordLinkCustomerId(Object(Magestore_Onestepcheckout_Model_Customer_Customer), 'ad706d238638a20...') #2 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Customer/controllers/AccountController.php(765): Mage_Customer_Model_Customer->changeResetPasswordLinkCustomerId('ad706d238638a20...') #3 /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Customer_AccountController->forgotPasswordPostAction() #4 /var/ww in /var/www/vhosts/impulsecbd.com/httpdocs/app/code/core/Mage/Eav/Model/Entity/Abstract.php on line 1553

  • I think in the database a attribute is useless, please check table eav_attribute. backend model not exist – Nguyễn Hồng Quân Sep 21 '18 at 3:50
  • Checked attributes database and I have no added attributes, just the default customer attributes i believe.... SELECT * FROM eav_attribute WHERE entity_type_id = 1 ORDER BY attribute_id ASC just the default set, I noticed on the edit custom information/password page on the backend that 'Disable Automatic Group Change Based on VAT ID ' checkbox was missing... not sure if thats supposed to be gone now or what but we upgraded to 1.9.3.10 recently. – Greg Walker Sep 22 '18 at 21:08
  • I also just noticed the 'forgot your password' link on the front end is doing the same thing... but if you log into the account and go to account information on the front end you are able to change the password from there... – Greg Walker Sep 22 '18 at 21:22
  • Error from forgot your password on the front end... – Greg Walker Sep 22 '18 at 21:24
3

Following error once patch is applied when trying to reset customer account password on the frontend.

Fatal error: Call to a member function getBackend() on a non-object in app/code/core/Mage/Eav/Model/Entity/Abstract.php on line 1536.

EDIT:

I noticed that the patch wasn't running the SQL upgrade script (app/code/core/Mage/Customer/sql/customer_setup/upgrade-1.6.1.0.1.2-1.6.1.0.1.3.php) which created a new attribute called rp_customer_id.

Check that you've cleared Magento Cache, and also clear the varnish cache if you have that enabled. After I disabled the cache storage, and cleaned varnish cache, the SQL script created the new attribute in the database.

  • Any idea what could be the problem when I get this error while I already have the rp_customer_id in the eav_attribute table? – Webninja Sep 17 at 12:26
0

Clearing cache didnt work for me, I had to reset customer password with the cache disabled.

Fixed this by disabling magento cache and then resetting customer password.

I enabled cache again and the password reset is still working.

0

I had this issue and noticed that I should have had an attribute called password_created_at in the eav_attribute table for entity customer.

This is created in app/code/core/Mage/Customer/sql/customer_setup/upgrade-1.6.2.0.5-1.6.2.0.6.php

Not sure why this didn't run, but I adjusted the core_resource table for customer_setup to 1.6.2.0.5 (version field) and cleared the cache so the setup reran.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.