3

I have follow below step https://docs.nexcess.net/article/how-to-set-up-magento-2-to-use-your-ssl-certificate.html

but i am getting below error

The web page at https://m2.key.com/ might be temporarily down or it may have moved permanently to a new web address. ERR_TUNNEL_CONNECTION_FAILED

  • try to flush and clean cache and reindexing. – Jimit Bhavsar Sep 20 '18 at 12:28
  • already tried that – Rutvee Sojitra Sep 20 '18 at 12:29
  • try to echo print in index.php file. check index.php file is called or not. – Jimit Bhavsar Sep 20 '18 at 12:33
  • yes checked not working – Rutvee Sojitra Sep 20 '18 at 12:33
  • Are you using any proxy ? ERR_TUNNEL_CONNECTION_FAILED error is a usually a proxy error , try to disable any proxy or vpn if you are using any , also check that the problem occur on every browser . – Radwan Sep 20 '18 at 12:42
0

Implementing SSL on Magento2 is so simple.. You can Install your SSL by cpanel and simply change the base url and secure base url from Magento2 Admin Panel stores->settings->configuration->general->web

After changing just do these commands

php bin/magento indexer:reindex
php bin/magento cache:clean
php bin/magento cache:flush
0

There are 2 ways of solving this issue:

Manually add the entry for web/secure/use_in_adminhtml into the core_config_data Add the following SQL query:

INSERT INTO core_config_data (scope,scope_id,path,value) VALUES ('default',0,'web/secure/use_in_adminhtml',1);

Change the URL in the table back to HTTP://your.domain.com/.

Clear the cache in both the cases by deleting /var/cache.

  • I want to make https url then why have to do http? – Rutvee Sojitra Sep 20 '18 at 12:36
  • I know but u can try it – Rv Singh Sep 20 '18 at 12:37
  • have tried not working – Rutvee Sojitra Sep 20 '18 at 12:38
  • For that in your database make some changes in core_config_data table. In table search "web/" from "search" tab in the header (using phpMyAdmin or similar). Edit web/unsecure/base_url and web/secure/base_url and paste the URL of your site. After that set value 0 to web/secure/use_in_frontend and web/secure/use_in_adminhtml. – Rv Singh Sep 20 '18 at 12:40
  • @RutveeSojitra try this in db side – Rv Singh Sep 20 '18 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.