4

Whenever I try to add or edit and save a product on Magento 2.2.5, I get the error "A technical problem with the server created an error. Try again to continue what you were doing. If the problem persists, try again later."

I've tried everything listed in this thread: https://github.com/magento/magento2/issues/10071

I've also tried looking for error logs, but I can't find any errors at all relating to this problem, only a 500 response code for the Ajax save request.

I was able to add products fine before I used the Magento Migration Tool, which was a little while ago, but I don't recall making any changes that would affect this, nor do I remember installing any other extensions since using the tool.

I've been Googling this all afternoon and I've found multiple answers on Stack Exchange, none of which help me. I've tried changing the admin password, creating a new admin user and making sure I've got full admin permissions. I've also tried re-indexing, clearing the cache, recompiling and manually deleting the cache files.

My closest guess so far is that the migration tool made some changes in the database that is causing it to error on trying to add a new product, although I'd expect to see an error for this. I also haven't found any other errors, so if it is this it's not a fundamental issue and obviously just not migrating the data isn't an option.

HELP!?

0

Have you tried to do a resave of the catalog price rules? Open the rules you already created, save them and try saving the products . If that doesn`t work remove url rewrites.

  • Thanks, I did try these, but they didn't help in my case. – Alex Gillon Sep 20 '18 at 15:23
0

After nearly two full days toiling over this, I've finally managed to resolve it! It was because I deleted some 'system' product attributes.

I was cautious when doing this and did lots of checks, but apparently didn't check saving a product! I was only trying to delete the attributes that came across during the migration, but I guess I'll just have to leave them there.

To resolve it I simply restored both the 'eav_attribute' and the 'catalog_eav_attribute' tables to as they were straight after the migration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.