2

I can't access my magento frontend. I get:

Access forbidden! You don't have permission to access the requested object. It is either read-protected or not readable by the server.

Backend works. I executed this inside the project folder to fix the permissions:

find . -type f -print0 | xargs -0 chmod 644
find . -type d -print0 | xargs -0 chmod 755

But that was not changing anything. I also deleted the cache after it.

I also tried:

find . -type f -print0 | xargs -0 chmod 777
find . -type d -print0 | xargs -0 chmod 777

...temporarily. No difference...

I also deleted my .htaccess file and tried it again. But still Access forbidden!

Im not sure what is going on?

  • Did you added any extension or any custom code? – Sukumar Gorai Sep 19 '18 at 9:24
  • Not recently. I just executed git pull on a old project. – Black Sep 19 '18 at 9:25
  • Can you check permissions to your project? I mean file permissions. – Sukumar Gorai Sep 19 '18 at 9:27
  • Seems to be correct – Black Sep 19 '18 at 9:30
  • Are you using xampp? – Sukumar Gorai Sep 19 '18 at 9:31
0

Solved! After disabling extension after extension I found out, that the extension GeoIP Extension, from Mageworx was causing the access denied error.

The Extension needed write permission to the folder media/mageworx/geoip but the folder was not existing and thus causing the error.

So the GeoIP Extension just blocked every IP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.